Solved Unable to set Intel license with sysctl [SOLVED]

sossego

Retired from the forums

Reaction score: 148
Messages: 1,557

Code:
# sysctl  legal.intel_iwi.license_ack=1
sysctl: unknown oid 'legal.intel_iwi.license_ack'
Currently using 8.2 i386 but, this also occurred with the recent release of 9.0.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,183
Messages: 11,426

This needs to be placed in /boot/loader.conf according to iwi(4). You appear to have it in /etc/sysctl.conf.
 
OP
sossego

sossego

Retired from the forums

Reaction score: 148
Messages: 1,557

No dice, people. It isn't doing diddly.
Code:
# ifconfig -a
iwi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
    ether 00:0e:35:53:a9:fe
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
fwe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=8<VLAN_MTU>
    ether 02:e0:b8:00:ba:fb
    ch 1 dma -1
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    lladdr 0.e0.b8.5.0.0.ba.fb.a.2.ff.fe.0.0.0.0
fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=2009<RXCSUM,VLAN_MTU,WOL_MAGIC>
    ether 00:e0:b8:6d:68:0b
    inet 98.211.110.13 netmask 0xffffff00 broadcast 255.255.255.255
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    inet6 ::1 prefixlen 128
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
# ifconfig wlan create wlandev iwi0
ifconfig: SIOCIFCREATE2: Input/output error
# kldload if_iwi
kldload: can't load if_iwi: File exists
# kldload iwi_bss
kldload: can't load iwi_bss: File exists
# kldload iwi_ibss
# kldload iwi_monitor
# ifconfig wlan create wlandev iwi0
ifconfig: SIOCIFCREATE2: Input/output error
# sysctl legal.intel_iwi.license_ack=1
sysctl: unknown oid 'legal.intel_iwi.license_ack'
Yet the sysctl variable is on the man page
http://www.freebsd.org/cgi/man.cgi?...ktion=0&manpath=FreeBSD+8-current&format=html

The firmware module was created and installed.

/boot/loader.conf has

Code:
legal.intel_iwi.license_ack=1
if_iwi_load="YES"
hw.physmem="1300M"
atapicam_load="YES"
wlans_iwi0="wlan"
ifconfig_wlan0="DHCP"
 

wblock@

Beastie Himself
Developer

Reaction score: 3,732
Messages: 13,851

sossego said:
/boot/loader.conf has

Code:
legal.intel_iwi.license_ack=1
if_iwi_load="YES"
hw.physmem="1300M"
atapicam_load="YES"
wlans_iwi0="wlan"
ifconfig_wlan0="DHCP"

The last two lines need to go in /etc/rc.conf instead.
 
Top