Unable to login in GUI mode after installation

I am trying FreeBSD for the first time. I installed FreeBSD 10.3 it on a GPT partition and got it to boot using Grub. After this I installed xorg, fluxbox, slim with:
pkg install xorg fluxbox slim

In /home/username/.xinitrc I put:
Code:
xterm &
exec fluxbox
To /etc/rc.conf I added:
Code:
slim_enable="YES"
Now when I boot I do not see the expected slim splash screen, instead it is a very basic username/password dialog, I think it is the xdm login screen(Note: It's not in console mode, it still is graphical). After I enter the username and password it returns to the same dialog but no error is shown. I am unable to use
Code:
ctrl+alt+Fn
(where n is between 1 and 7) as the screen remains fixed at the username/password dialog. The only way I can login is either using SSH or if I comment this line in /etc/ttys:
Code:
ttyv8    "/usr/local/bin/xdm -nodaemon"    xterm    on  secure
Is there any step I am missing or how can I check what is not working as it should.
 
did you create a .xinitrc file in your home directory? If not, do so and add the following line to it:
Code:
exec startfluxbox
 
Start here: Handbook: 5.4. Xorg Configuration

Note, for slim your ~/.xinitrc should look something like this:
Code:
#!/bin/sh

DEFAULT=startfluxbox

[ -n $1 ] && exec $1

# Fallback in case startx is used
exec ${DEFAULT}

Do NOT enable XDM or Slim using /etc/ttys!
 
I'm one of those who use /etc/ttys to start XDM; which are the drawbacks?
There's a possible conflict between ttys and xdm. It also makes it rather difficult to restart XDM without restarting the whole system.
 
I got that I was supposed to use startfluxbox instead of fluxbox but even after making the change /home/username/xinitrc to:
Code:
exec startfluxbox
I have the same result. As for slim configuration, it should fall back to the default i.e. exec startfluxbox but it doesn't
 
Make sure dbus is running. I'm not sure if it's the cause (or if Fluxbox really needs it) but a lot of applications (especially Window Managers) seem to depend on it nowadays. So it doesn't hurt to enable it.

Forget Slim for a minute, disable it for the time being. Does Xorg/Fluxbox start correctly if you use startx?
 
Make sure dbus is running. I'm not sure if it's the cause (or if Fluxbox really needs it) but a lot of applications (especially Window Managers) seem to depend on it nowadays. So it doesn't hurt to enable it.

Forget Slim for a minute, disable it for the time being. Does Xorg/Fluxbox start correctly if you use startx?
dbus is enbled in /etc/rc.conf , if I use startx the screen just goes blank.
 
if I use startx the screen just goes blank.
Right, focus on this first. It's an indication things haven't been set up correctly yet. Can you post a Xorg.0.log and provide us some information about your hardware (specifically which videocard)?
 
Right, focus on this first. It's an indication things haven't been set up correctly yet. Can you post a Xorg.0.log and provide us some information about your hardware (specifically which videocard)?
Thanks for your response, I was away for a bit. The complete Xorg.0.log is at http://pastebin.com/jZMs0JHD

I haven't been able to locate anything in the file that would indicate X server failed to load.
 
I got bitten by modifying /etc/ttys to start XDM. Now I get a different login screen, which does not recognize my login and password. I have everything else working... now this.... Ugh!

HELP me !
 

Attachments

  • 20171204_113819.jpg
    20171204_113819.jpg
    1.1 MB · Views: 581
Boot to single user mode, remove the entry from /etc/ttys and start normally.
 
Back
Top