Unable to load PHP Suhosin

rjani1

New Member


Messages: 2

I am unable to load PHP Suhosin which I had installed from the FreeBSD ports collection. Here is full error message I get when I look in the php-errors.log file:

Rich (BB code):
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0
In my php.ini file I have following extenstions loaded:

Code:
; UNIX Extensions
extention=session.so
extension=suhosin.so
Also I have following extension files under /usr/local/etc/php:

ext-18-session.ini
...
ext-30-suhosin.ini

If I run php -v I get the following:

Code:
PHP 5.6.34 (cli) (built: Apr  3 2018 02:04:04)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Suhosin v0.9.38, Copyright (c) 2007-2015, by SektionEins GmbH
From the above Suhosin clearly seems to be acknowledged but am not sure why the error message is getting reported.

I also done a quick update/upgrade as well but FreeBSD just reports that nothing needs to be done:

Code:
pkg update
pkg upgrade -f php-suhosin
pkg upgrade
My OS version is 11.1-RELEASE.

Any ideas what might be happening? Let me know if more information is required.
 

ShelLuser

Son of Beastie

Reaction score: 1,747
Messages: 3,565

You say that you installed it from the ports collection, but you show to be using pkg commands which use the binary package repository. So how exactly did you install this?

Because you almost make it sound as if you combined building ports and installing binary packages, which could definitely explain the problems you're having.
 
OP
OP
R

rjani1

New Member


Messages: 2

You say that you installed it from the ports collection, but you show to be using pkg commands which use the binary package repository. So how exactly did you install this?

Because you almost make it sound as if you combined building ports and installing binary packages, which could definitely explain the problems you're having.
Just to clarify I installed from /usr/ports/security/php-suhosin. I did not use the pkg facility before or afterwards. Sorry for the confusion in the OP.
 
Top