Unable to Get GLX to Initialize with Nvidia Driver

aorchid

Active Member

Reaction score: 3
Messages: 120

I believe that is the problem.

Running fresh install of 8.0-RELEASE-p2 with everything built from ports. I have a GeForce GTX 285 that worked fine when I ran PC-BSD for a couple of days, so the driver should work. I am unable to enable compositing in KDE4 (originally posted there and my Xorg file is there). Looking more closely at the Xorg.log file I see this:

Code:
(EE) May 05 06:10:04 NVIDIA(0): Failed to initialize the GLX module; please check in your X       
(EE) May 05 06:10:04 NVIDIA(0):     log file that the GLX module has been loaded in your X        
(EE) May 05 06:10:04 NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If     
(EE) May 05 06:10:04 NVIDIA(0):     you continue to encounter problems, Please try                
(EE) May 05 06:10:04 NVIDIA(0):     reinstalling the NVIDIA driver.

This follows after what looked to me like loading of the module:

Code:
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.7.5, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(==) AIGLX disabled
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.7.5, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource

I then thought that I should rebuild nvidia-driver, so I did a make config and make install clean, but oops! Now I have this and I think I have really messed this up.

Code:
===>  Checking if x11/nvidia-driver already installed
===> src (install)
install -o root -g wheel -m 555   nvidia.ko /boot/modules

/: write failed, filesystem is full
install: /boot/modules/nvidia.ko: No space left on device
*** Error code 71

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86_64-195.36.15/src.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86_64-195.36.15.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.


So, any suggestions on why the glx module was not loading? Also, now can I now get the driver to reinstall?

Thanks very much for any suggestions,
aric
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,237
Messages: 11,441

Create more space on / (see error) and reinstall the NVIDIA driver. This will replace the X.Org GLX module.
 
OP
aorchid

aorchid

Active Member

Reaction score: 3
Messages: 120

Thanks and sorry about the formatting issue.

I am new to Freebsd and I am not sure how I would add more space to / while logged in? (sorry :( )

Here is the output of:
[CMD=""]df[/cmd]
Code:
Filesystem         1K-blocks     Used     Avail Capacity  Mounted on
/dev/label/rootfs0    507630   499904    -32884   107%    /
devfs                      1        1         0   100%    /dev
/dev/label/var0      1012974   216142    715796    23%    /var
/dev/label/usr0    182753824  9047894 159085626     5%    /usr
fitz/home          923966848        0 923966848     0%    /home
fitz/home/aorchid  937861248 13894400 923966848     1%    /home/aorchid
fitz               923966848        0 923966848     0%    /fitz
fitz/Rworkarea     931616256  7649408 923966848     1%    /fitz/Rworkarea
fitz/music         935885696 11918848 923966848     1%    /fitz/music
fitz/pictures      924400640   433792 923966848     0%    /fitz/pictures
 
OP
aorchid

aorchid

Active Member

Reaction score: 3
Messages: 120

I see, I had it all in command rather than cmd then code. Looks nicer...
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,237
Messages: 11,441

Run [cmd=]du -k -x -d 1 /[/cmd] and see where you can create some space. If /boot is by far the greatest directory, remove the *.symbols files from /boot/kernel.
 

sk8harddiefast

Daemon

Reaction score: 203
Messages: 2,157

First deinstall nvidia driver.Go to /usr/ports/x11/nvidia-driver
Then
Code:
sudo make deinstall clean
This will deinstall (remove) nvidia driver from your system.
Now to install it again.
Code:
sudo make install clean
And now go to /boot/loader.conf and add this line
Code:
nvidia_load="YES"
This will load nvidia driver everytime you startup your system.
Also install from ports nvidia-settings & nvidia-xconfig (are on /usr/ports/x11/)
kldload the driver again.
Now run.
Code:
sudo nvidia-xconfig
This will create xorg.conf file.BUT he will create it on home directory so go to your home directory and run
Code:
sudo cp xorg.conf /etc/X11/xorg.conf
Now you have xorg.conf on /etc/X11
For composite try to install this lines on your /etc/X11/xorg.conf
Code:
Section "Extensions"
Option "Composite" "Enable"
EndSection
Reboot your system
Sorry but i don't know what to do to increase your space :(
This is all i did to make my nvidia driver work properly.So if you fix the space error i hope this should make your nvidia work fine
 
OP
aorchid

aorchid

Active Member

Reaction score: 3
Messages: 120

OK. Thank you very much for that. Now it seems that the critical module extensions are not being installed.
Code:
freeenv# cat pkg-plist                                                              
@comment I can't add the below files to the package because pkg_delete              
@comment will complain when removing this package:                                  
@comment     %%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%%          
@comment     %%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%%          
@comment     lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%%                               
@comment They are however restored when this package is removed:                    
@exec mv -f %D/%%MODULESDIR%%/extensions/libglx.la %D/%%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%%
@unexec mv -f %D/%%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%% %D/%%MODULESDIR%%/extensions/libglx.la
@exec mv -f %D/%%MODULESDIR%%/extensions/libglx.so %D/%%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%%  
@unexec mv -f %D/%%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%% %D/%%MODULESDIR%%/extensions/libglx.so
@exec mv -f %D/lib/libGL.so.1 %D/lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%%                                            
@unexec mv -f %D/lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%% %D/lib/libGL.so.1

I had already run make deinstall prior to attempting to remake and install again. But it looks like I am missing a step here.
 
OP
aorchid

aorchid

Active Member

Reaction score: 3
Messages: 120

Thank you both very, very much for your assistance and patience. It does finally work properly. Not sure which step corrected it, but I am very appreciative of both of your assistance.

thanks, aric
 

rockmastermike

New Member


Messages: 1

thanks

This (reinstalling the nvidia driver and running nvidia-xconfig) fixed it for me too. Not sure why, since it was a fresh install of the nvidia driver.

thanks
 
Top