Ugrade 10.3 -> 11.0 issues

The only way I could install 11.0 was to upgrade 10.3 as 11 would not boot on my machine (see separate thread),

The upgrade sort of worked (after many hours of patches & upgrading packages), however, there is at least one issue with the upgrade.

The package hplip would not upgrade, and a re-install of it produced the following error
pkg install hplip
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 5 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
   hplip: 3.17.4
   sane-backends: 1.0.27
   py27-pillow: 3.4.2_1
   py27-sip: 4.19.2,1
   py27-qt5-dbussupport: 5.7.1

Number of packages to be installed: 5

The process will require 39 MiB more space.

Proceed with this action? [y/N]: y
[1/5] Installing sane-backends-1.0.27...
===> Creating groups.
Using existing group 'saned'.
===> Creating users
Creating user 'saned' with uid '194'.
pw: user 'saned' disappeared during update
pkg: PRE-INSTALL script failed

Any idea's how to fix this? .. and will this likely happen with other packages?
.. and will this likely happen with other packages?
Yes, your password databases seem to be out of sync for whatever reason, so every package that creates a user will have the same problem. Run /usr/sbin/pwd_mkdb -p /etc/master.passwd to fix it.
Many thanks for the prompt reply ... that did the trick.

I can now set up my printer with localhost:631 .... wish I could figure out what packages to load to get gnome print manager to work.
(I tried the gnome-cups-manager ... but that did not do it)
There seems to be other issues too with the upgrade.

gnome-control-center will not run with the following error:
Shared object "" not found, required by ""

I tried re-installing both libldap and libsmbconf, but can't find those packages