Solved trying to set up a network bridge for dhcp

sdad

Member

Reaction score: 1
Messages: 35

I constructed a bridge in /etc/rc.conf :

Code:
cloned_interfaces="bridge0"
ifconfig_bridge0="addm bge0 addm bge1 up"
ifconfig_bge0="up"
ifconfig_bge1="up"
ifconfig_bridge0="DHCP"


A reboot did give me an address for my admin interface (separate device, same dhcp server, I didn't list it), but not for the bridge

I did a command line:
ifconfig bridge0 inet DHCP (this returned a subnet of 199.x.x.x, my server is on 192.x.x.x),

I tried setting a static address, this worked command line. Now in this case static will work for me, but I'm consumed with finding out why the dhcp doesn't.

I also tried:
dhclient bridge0 (this failed to get a dhcpoffer).

I did not create anything in /etc/dhclient as yet, first because a dialog said that a empty file works for most. Maybe this is not one of the "most". If I need file, a couple of questions

1) What do I use for the client id? I assume it is the bridge id, but that is a randomly generated value, but is that value persistent after initial build? If it is then I feel ok about using it, but if it isn't?

2) How do I find out the media type so I can fill in that line?


Below is the suggested code I found to enter into /etc/dhclient.conf. I would change ep0 to bridge0 and so on, but unsure on those 2 lines I asked about above.

Code:
timeout 60;
	   retry 60;
	   reboot 10;
	   select-timeout 5;
	   initial-interval 2;

	   interface "ep0" {
	       send host-name "laptop.nixcraft.in";
	       send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
	       send dhcp-lease-time 3600;
	       supersede domain-name "nixcraft.net.in r.nixcraft.com r.vsnl.nixcraft.net.in";
	       prepend domain-name-servers 127.0.0.1;
	       request subnet-mask, broadcast-address, time-offset, routers,
		       domain-name, domain-name-servers, host-name;
	       require subnet-mask, domain-name-servers;
	       script "/etc/dhclient-script";
	       media "media 10baseT/UTP", "media 10base2/BNC";
	   }

	   alias {
	     interface "ep0";
	     fixed-address 192.5.5.213;
	     option subnet-mask 255.255.255.255;
	   }
 
OP
S

sdad

Member

Reaction score: 1
Messages: 35

I solved my issue
First I removed the
Code:
ifconfig_bridge0="DHCP"
line.

I changed
Code:
ifconfig_bridge0="addm bge0 addm bge1 up"
to
Code:
ifconfig_bridge0="addm bge0 addm bge1 SYNCDHCP"

Played well after that, in fact this reply being sent through the bridge.
 
OP
S

sdad

Member

Reaction score: 1
Messages: 35

OK, I'll do what I can, certainly is much more readable!
 

wheelcomplex yin

New Member

Reaction score: 2
Messages: 2

I solved my issue
First I removed the
Code:
ifconfig_bridge0="DHCP"
line.

I changed
Code:
ifconfig_bridge0="addm bge0 addm bge1 up"
to
Code:
ifconfig_bridge0="addm bge0 addm bge1 SYNCDHCP"

Played well after that, in fact this reply being sent through the bridge.

Thank you very much, SYNCDHCP save me from the hell, after spent five hours to setup bridge with dhcp in FreeBSD 11.
 
Top