Solved Trying to modify /etc/rc.conf but get 'unable to create file "/etc/rc.conf"'

I've been trying to install Gnome for my FreeBSD. This is the first time I got this far. I modified /etc/rc.conf to include
I rebooted, but all I got was a black screen after the computer displayed all tech jargon I can't understand. I got back into the /etc/rc.conf and say that I hadn't added gdm_enable="YES". So I added it. But when I went to save and exit, it gave me the error in the title.

I logged into a simple user then logged back in as root to make sure I had adequate permissions. Then I tried to modify the file but was met with the same error. I ran ls -l to make sure, double sure, I had adequate permissions. Still nothing.

I dug around the interwebs, and as far as I can tell no one outside the former Soviet Union has run into this problem. Any suggestions?

My apologies if I am a potato and this question has been answered. I searched around these fora and didn't find anything close.

EDIT: I found a solution for this particular problem.
It's good that you found a solution, but it would be helpful for future readers to know what that solution was.
Sorry. I am a potato.

I ran the following commands:

# fsck
# mount -u /
# mount -a -t ufs

That took care of it.