Trying to install Google earth

using ports (all fresh) I tried installing google-earth. Install went fine, all dependencies pulled in, I think. I can't launch the app even as root (permission denied) so I changed permissions to 777. Trying ./google-earth.desktop after changing permissions gives
Code:
# ./google-earth.desktop
./google-earth.desktop: [Desktop: not found
./google-earth.desktop: Earth: not found
./google-earth.desktop: planet: not found
./google-earth.desktop: search: not found
./google-earth.desktop: %f: not found
./google-earth.desktop: Network: not found
./google-earth.desktop: application/vnd.google-earth.kmz: not found
./google-earth.desktop: application/earthviewer: not found
./google-earth.desktop: application/keyhole: not found
root@BrianFreeBSD:/usr/local/share/applications # exit
exit
$ googleearth
ELF binary type "0" not known.
exec: /compat/linux/bin/sh: Exec format error

I can find google earth in apps in KDE kickoff but it just bounces around for a while then nothing. It seems like several apps aren't there and the not found items are from wherever that I don't know. any ideas?
Thanks
 
I can't launch the app even as root (permission denied) so I changed permissions to 777.
Please stop doing this. It's NEVER a solution and it NEVER helps. Unless you're dealing with MAC (Mandatory Access Control) root will ALWAYS have access to everything regardless of file permissions. So, don't even try it. There's a good chance you'll forget to reset it to the proper permissions, leaving your system vulnerable.
 
Ouch! Well, root didn't open this app. I tried as user, no luck. changed to root, permission denied. Looked at permissions and there were not options for executing the file by root, group or wheel. So what else was I supposed to try? I'll just deinstall google-earth since I can't get it to work and then no more permissions issues.
 
I did cd /usr/ports/emulators/linux-c6 && make install clean and cd /usr/ports/astro/google-earth && make install clean. Then ee /etc/fstab adding
Code:
linprocfs       /compat/linux/proc      linprocfs       rw      0       0
and
Code:
tmpfs           /compat/linux/dev/shm   tmpfs   rw,mode=1777    0       0
plus mount /compat/linux/proc plus mount /compat/linux/dev/shm then googleearth &. With the linux modules loaded, googleearth starts ok. Note: all commands are used with su - login except googleearth & . Use googleearth & as normal user.
 
I did cd /usr/ports/emulators/linux-c6 && make install clean and cd /usr/ports/astro/google-earth && make install clean. Then ee /etc/fstab adding
Code:
linprocfs       /compat/linux/proc      linprocfs       rw      0       0
and
Code:
tmpfs           /compat/linux/dev/shm   tmpfs   rw,mode=1777    0       0
plus mount /compat/linux/proc plus mount /compat/linux/dev/shm then googleearth &. With the linux modules loaded, googleearth starts ok. Note: all commands are used with su - login except googleearth & . Use googleearth & as normal user.
I'll deinstall googleearth and try your method. seems to be a great solution that I would never have figured out! Most gracious thanks and I'll let you know.
 
I deinstalled and followed your method exactly. No build problems. Exited root shell and then this:
Code:
$ googleearth &
$ ELF binary type "0" not known.
exec: /compat/linux/bin/sh: Exec format error

[1]   Done(126)               googleearth
Any ideas? I truly appreciate the help!

I apologize for extra posting but I did add
Code:
linux_enable="YES"
in etc/rc.conf
 
This is reallllllllly good!
I had this problem for months and only now discovered this thread,
fstab, and the linux loading in rc.conf did the trick. Yesterday, beforehand I did a kldload linux64 but googleearth crashed after the splash.
 
Last edited by a moderator:
Back
Top