Trying to install FreeBSD on a 20 year old laptop

Good afternoon:

I am trying to install FreeBSD on an old laptop with the following specs:

Intel Celeron 1000MHZ, 128MB RAM and HD 18.6 GB. It is a 20 years old computer with CD-ROM, floppy disk and a BIOS that I think does not accept USB booting (I have not seen that option in the BIOS) but I have not tried to insert a usb with a FreeBSD image either. The option to install from floppy is completely out of the question.

So far, I have tried 12.4 RELEASE-i386-disc1.iso, 13.1-RELEASE-i386-bootonly.iso and 13.1-RELEASE-i386-disc1.iso but I cannot complete the installation. Either it can't load the kernel or it shows the error:

Can not open /boot/lua/loader.lua (this in version 12.4-release).

The only version I managed to install (years ago) and now is an old iso image with version 7.2 Release, but it is not functional because the ports are totally outdated and I can't even use a browser because of the certificates issue.
I have also tried to update this system once installed, but it is only applicable to patches and there is no option to download ports or packages for this version, or at least I have not managed to do it.

My idea is to install the minimum system that can work and then some light graphical manager, such as XFCE or similar. If I don't get it I will definitely discard the laptop.
Any suggestion will be welcome. Thanks in advance.

I think your HDD is fine but 128MB Ram sounds a bit thin. And than adding X11 and XFCE to the base?
I don't think this will happen.
But interesting anyway. Please post the outcome.


Connect the harddrive to a bigger computer and install there, then move it back. Presumably requires a P-ATA to USB adapter, but those are cheap.

So it seems the CD drive is broken?
Try Plop if it doesn't support usb boot or PXE. Memstick image for USB. You will need to use a minimal window manager. Xfce is too heavy for 128MB RAM.

It's an old AMD Athlon PC. I gave up on spinny disk things and wrote the ISO to a USB stick. This has worked and I am now configuring my shiny new FreeBSD install.

I don't think this issue is fixed. There's still configurations whereby the CD-ROM presence causes the loader to get confused. This results in the loader not being able to read the boot fixed disk. In my case, it was a 17TB RAID6 disk connected to a PERC H700. I disconnected the CD-ROM and disabled the SATA ports and then my Dell T610 was able to boot/reboot (12.1-RELEASE and various builds of 12-STABLE).
unless the box is something very special, you better trash it
you can get cheap / low power 64bit boxes for probably around $30-$50 that will be faster, 64bit, lots more memory
,use (a lot less) energy and are dead silent
Even you have installed any supported FreeBSD, you can't use it with graphics for any real task.
No modern web-browsers can run on CPU without SSE2.
So you can install FreeBSD on this device, but it has a reason only just for fun.
A decade ago I used "Frenzy" - FreeBSD-based lightweight distro.
It was amazing, I used it with GUI on Pentium III 600Mhz laptop like "Compaq armada m300"
I found the site try to use it if you want.
Also I have Frenzy iso image, ask me if you will need it and have no success with downloading anywhere.

Another way is to Install Windows XP and connect to modern PC via Remote Desktop Client mstsc.
It allows to use the device as a thin client.
A few years ago, I've seen similar threads on these Forums. I'm a bit too lazy to look them up right now, but off the top of my head, I recall that the overall strategy was to find an older FreeBSD release (see and get something that's about 5-6 years younger than the laptop. Then get the kernel upgraded... in small, incremental steps, like from 7.2 to 8.0 to 9.0, and so on.

After the updates, OP can use /bin/fetch to get the latest tarball of ports. But yeah, with minimal specs like OP's, TWM is OP's best bet.

My concern would be about the disk... It may be just too rusty after all these years. I have an cheap laptop with an HDD that I bought in 2015 or so as an emergency spare. And by now, that HDD is so rusty, stuff is VERY slow to be read off it for launch. Wi-fi on that device is not great, either, and the battery not charging any more. So I'm in the process of running DBAN on the disk, and you'd think that after 3 days (72 straight hours), the 465GB HDD would be zeroed out... Nope, barely over 1%. Gonna trash that laptop. And after that, I'm gonna be HDD-free. I swear by SSDs here... :p
Thank you very much to all of you for your answers.

Yes, the truth is that I had the laptop there forgotten in a corner and I was thinking of "retiring" it definitively, but I turned it on and as I had FreeBSD 7.2 installed on it for years running XFCE (working reasonably well), I thought of trying to install a slightly newer version, as now I couldn't use any browser and everything was outdated.

At first, I tried with some light Linux distro (Trisquel, AntiX, Q4os) but none of them works with less than 256 MB except AntiX in the net version (without graphical environment and with a minimal system).Trisquel got stuck and in the end it would not finish loading. Q4os surprised me because in a graphical environment it warned me that my system had less than 256MB of RAM and could not continue with the installation.
Then I tried with FreeBSD 12.4 and failed to install it, the same with 13.1 in its bootonly version that fails to load the kernel, so I successfully reinstalled version 7.2 on the first try (as before) from a CD, and I could have continued with the ports, but I would encounter the same problem as above.

I don't know the reason, but to say, that since a few years ago I am encountering problems to install on my current PC Linux distros from a CD, and in the end I almost always have to do it from a USB, so I think this is a generic problem that should be improved by the developers, otherwise there is no point in burning an iso image on a CD.

I will have to weigh some of this advice. Thanks again.
I still do not understand what problem the OP has with the CDROM drive that results in not finding the kernel.
OP was not explicit so my best guess is the CD-ROM is actually a DVD-ROM. In any case the ISOs are too big to fit on 700 MB or 4.7 GB media. Most folks use an 8GB or larger USB stick.
the boot only iso should fit on anything
you can also probably hack it to install from the hdd by creating an "install partition" with a 7.2 boot iso but the hardware is too old/weak to get an usable desktop


Guys? What happened to "The Heck Of It" reason for doing things?
Thanks. This. :cool:

I only really need i386 packages for wine, for that a pretty small set would suffice. Still, I try keeping "alive" some weak and old Asus EeePC, it should have some "usable" (of course horribly slow) GUI with web browser. That way, I already ran into lots of build-problems on i386 and managed to get some of them fixed ;)

Does it "make sense"? Yes! Cause, why not?