ZFS Trying to import damaged ZFS pool with replaced drive

Hi All, I hope everyone is doing well. I've found a heap of useful info on these forums, but this is my first post, so I hope I'm not asking too much of this brilliant community.

I had a drive fail on a four drive ZFS pool a few years back and because I did not have another drive or the knowledge at the time I just turned the server off and called it.

Today I decided maybe it was time to resurrect this pool as it has a heap of files on it that I would like to recover.

I have attached a file from napp-it in relation to the pool.

I've put another drive into the slot of the failed drive but it appears like it's saying it cannot open both the new one and one of the other existing ones. One thing to note is the replacement drive is not the same size as the drive it is replacing, but I did not have the drives full, so I am not sure if this is a problem or not. Alternatively, I'd like to find a way to access what I can from the pool so I can recover it and then create a new pool.

Any help would be great! Thanks in advance.

Jeff
 

Attachments

  • Screen Shot 2017-01-07 at 12.10.51 pm.png
    Screen Shot 2017-01-07 at 12.10.51 pm.png
    122.4 KB · Views: 499
Okay, now I have it showing as Degraded and I have replaced the third 2TB drive, which is dead, with a 1TB drive, which I have no idea if I can use for the pool, and how I would add it to the pool.
 

Attachments

  • Screen Shot 2017-01-07 at 1.40.50 pm.png
    Screen Shot 2017-01-07 at 1.40.50 pm.png
    44 KB · Views: 437
First, you cannot replace a disk of one size with a disk of a smaller size. It must be of equal or greater size. That's a basic limitation of all RAID implementations, not just ZFS. (Weird storage schemes like drobo and Storage Spaces notwithstanding).

Second, if the pool is several years old, scrap it and create a new one. If you're only coming back to it years later it obviously didn't have vital data on it, and the ZFS version running on it is going to be very out-of-date.

Third, if you're trying to resurrect a Napp-it appliance---not just use the disks with FreeBSD---you're in the wrong place. Napp-it is Solaris-based, and runs its own modified version of OpenSolaris at that. You'll need to ask their support community for more help.
 
Hi Anoknusa,

Yeah I wasn't sure about the disk thing, I thought I read somewhere I could with ZFS, but I am obviously mistaken.

I would like to recover what is on it. The reason I shut it down is because I didn't have the knowledge and I didn't want to destroy the data that was on it as ultimately, I would like to recover it. While I am using the napp-it app on the front end, I have been trying to use the base terminal to mount and recover the data that is on there. I have other drives and locations I can move the data to, if only I could access it.

Thanks for the advice, I will go look for a different forum which may have a better idea of how to get the data off.

Cheers,
Jeff
 
I would like to recover what is on it.
As far as I can see your pool now is online, even if in degraded state, and your data should be there.

All you need to do now is to import the pool, possibly on a temporary mountpoint, say /mnt
Code:
zpool import -f -o altroot=/mnt RaidVol
see zpool(8) for further details.

The 4th disk, if available, is supposed to provide data redundancy, you can recover your data without it.
 
Hi ASX, I have tried importing the pool a few times, but it never seems to finish. After 24 hours of trying, it is still not imported or accessible. Does this indicate a problem with the pool that cannot be resolved?
 
I have no idea (nor experience) about your results, zpool import usually take just a few seconds.
 
Back
Top