• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Troubleshooting ACPI Sleep 3

RevennaFox

New Member


Messages: 15

#1
For some reason I'm trying to get FreeBSD installed on a notebook (weird, I know) and I'm having trouble getting sleep mode working right. If you run acpiconf -s 3 (or even quit X with Ctrl-Alt-Backspace) while X is running, the screen does this, and if you run it from the command line everything just freezes up and you have to reset it. I ran into a similar problem with an IBM Thinkpad R40 I used to have, where switching to newcons fixed the glitchy screen but I never did get sleep mode working on it either.
I'm running FreeBSD 10.3-RELEASE with the stock kernel on a Panasonic Toughbook CF-51 with the godawful Intel 82915/i915 chipset/graphics and Pentium M 780 CPU. Full dmesg is here.
 

RevennaFox

New Member


Messages: 15

#3
Cool, here we go:

sysctl hw.acpi.supported_sleep_state
hw.acpi.supported_sleep_state: S3 S4 S5

acpiconf -s 3
Does nothing for a second, then freezes up and won't respond to key presses. Probably not only the video because I tried switching to a different virtual console and trying to run shutdown -r now and nothing happened, unless the video can completely freeze it up.

sysctl debug.acpi.suspend_bounce=1
acpiconf -s 3
Screen flickers for a second then comes right back.

kldload acpi_panasonic
acpiconf -s 3
System stays responsive for a few seconds, then completely locks up. Trying to run commands produces no results.

devinfo -rv
pciconf -clv
 
Top