Trouble with an interrupt storm at irq 19

y2s82

Member

Reaction score: 1
Messages: 68

My computer is having interrupt storm at irq 19. It starts as soon as the computer starts. It's using up one of my duel cores entirely. I've done some searching, but there doesn't seem to be much of a way to resolve this.

I'm using Freebsd 8.0-p2. I'm attaching vmstat -i and dmesg | grep irq\ 19. Please let me know if there's anything else that needs be addressed. Thank you all in advance. :)

vmstat -i
Code:
interrupt                          total       rate                            
   2 irq1: atkbd0                      138623          1
   3 irq9: acpi0                      6463839         47
   4 irq12: psm0                         2337          0
   5 irq19: uhci2 ehci*             411672028       3039
   6 irq23: uhci3 ehci1               1499437         11
   7 cpu0: timer                    270906260       1999
   8 irq256: hdac0                    4817938         35
   9 irq257: re0                     25310727        186
  10 cpu1: timer                    270905173       1999
  11 irq258: vgapci0                 18050570        133
  12 Total                         1009766932       7454
dmesg | grep irq\ 19
Code:
 uhci2: <Intel 82801I (ICH9) USB controller> port 0x1860-0x187f irq 19 at device
   2 ehci0: <Intel 82801I (ICH9) USB 2.0 controller> mem 0xf0904000-0xf09043ff irq 1
   3 pcib4: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
   4 re0: <RealTek 8168/8168B/8168C/8168CP/8168D/8168DP/8111B/8111C/8111CP/8111DP PC
   5 uhci4: <Intel 82801I (ICH9) USB controller> port 0x18a0-0x18bf irq 19 at device
   6 atapci0: <Intel ATA controller> port 0x18f8-0x18ff,0x180c-0x180f,0x18f0-0x18f7,
   7 atapci1: <Intel ATA controller> port 0x1c50-0x1c57,0x1c44-0x1c47,0x1c48-0x1c4f,
 

mav@

Aspiring Daemon
Developer

Reaction score: 218
Messages: 702

One interrupt storm was fixed in ata(4) driver in 8-STABLE. You may need to update your system.
 

mav@

Aspiring Daemon
Developer

Reaction score: 218
Messages: 702

Have you tried to update to -STABLE? One interrupt storm problem in ATA was fixed few months ago.
 
OP
OP
Y

y2s82

Member

Reaction score: 1
Messages: 68

:(

i have updated to stable since the last post. Been doing so every weekend. The interrupt storm remains the same. :(

i guess more waiting? if anyone's interested in solving the problem, please let me know for more info (and also tell me how to produce such info haha i'm such a noob...)
 

neeraj

New Member


Messages: 3

I have used the latest Free BSD. My System Info is:

Process Core i3 64 bit (4-cores)
SATA HDD
4 GB DDR3 RAM
Intel HD Graphic card
24" HD 1080p Monitor
6 USB ports (Intel series 8/9)

if this can help in solving the problem.

PS: irq 19 belongs to which device?
 
OP
OP
Y

y2s82

Member

Reaction score: 1
Messages: 68

@neeraj
if you look at my first post top of this list, you'll find that i found the devices for irq19 by doing
Code:
dmesg | grep irq\ 19
You might also want to make sure that's the source of the irq storm...

Anyhow, does anyone have any comments or suggestions as to how to resolve the issue? it sux to have to render the dual core system into single core because of a software prob :(
 

Floux

New Member


Messages: 1

i had the same problem and i resolved it. Try to active AHCI in your bios. It worked for me.
 
OP
OP
Y

y2s82

Member

Reaction score: 1
Messages: 68

@Floux
AH!!! I hope you are a girl because I think I'm in love with you! :D
That did the trick :) That option was hidden in my BIOS, but recently while playing around with the setting, I switched the BIOS setting from Windows XP to Vista, and the option to switch to AHCI showed up! Now the interrup storm has stopped.

So thanks for everyone who've been attentive to this problem. cheers all :)
 

neeraj

New Member


Messages: 3

Can't FIND AHCI in BIOS

Floux said:
i had the same problem and i resolved it. Try to active AHCI in your bios. It worked for me.
Sadly I don't have that option in BIOS or any other relevant option. I guess I am really stuck x(
 
OP
OP
Y

y2s82

Member

Reaction score: 1
Messages: 68

I had a similar situation. rather, my option was hidden.
The option showed up when I was playing around with another setting in the BIOS about the operating system.
If you can find a menu that asks you about the operating system, try something later than XP and not "Other". In my case, Vista was the one that opened up the AHCI option.
Good luck. And also see if you can update your BIOS. maybe they'll have such option in a later revision.
 
Top