• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Trouble running sudo or (less ) after making serial settings

ali reza

New Member


Messages: 6

#1
hello
After making serial settings and boot using serial via putty, it is not possible to run sudo command. When I run this command without any parameters it should be print help but it is waiting for a key of the keyboard.
If I send ctrl+c then output strings are printed.

Code:
settings :
boot.config =>-S115200 -D
----------------------------------------------
/etc/ttys =>ttyu0   "/usr/libexec/getty std.115200" vt100   onifconsole secure
----------------------------------------------
echo $TERM => vt100
----------------------------------------------
kern.vty=vt
----------------------------------------------
ssty -a =>
speed 115200 baud; 0 rows; 0 columns;
lflags: icanon isig iexten echo echoe -echok echoke -echonl echoctl
        -echoprt -altwerase -noflsh -tostop -flusho -pendin -nokerninfo
        -extproc
iflags: -istrip icrnl -inlcr -igncr ixon -ixoff ixany imaxbel -ignbrk
        brkint -inpck -ignpar -parmrk
oflags: opost onlcr -ocrnl tab3 -onocr -onlret
cflags: cread cs8 -parenb -parodd hupcl -clocal -cstopb -crtscts -dsrflow
        -dtrflow -mdmbuf
cchars: discard = ^O; dsusp = ^Y; eof = ^D; eol = <undef>;
        eol2 = <undef>; erase = ^?; erase2 = ^H; intr = ^C; kill = ^U;
        lnext = ^V; min = 1; quit = ^\; reprint = ^R; start = ^Q;
        status = ^T; stop = ^S; susp = ^Z; time = 0; werase = ^W;
---------------------------------------------------
 
Last edited by a moderator: