Solved trouble making a bootable USB with freeBSD 10.3


I'm having trouble making a bootable USB stick with freeBSD 10.3.
This is my first try at installing freeBSD, i really want to try this OS out, to see if it's something for me. I come from a GNU/linux Debian background, which i've used blindly for over 10 years. Now it's time to try something new. To be honest i think linux have become very messy and chaotic. I've read alot about freeBSD and it seems promising :)

Here's what i've done so far:
  • tried downloading a .iso and write the image to USB using 'unetbootin', big mistake. This software is built to write linux distros to USB only. N00b mistake.
  • After some hours trying to make it work with unetbootin, by trying different versions of the software, and trying older images of freeBSD. Nothing worked of course.
  • So now i've reached the conclusion that this method isn't of any use. And found some official advice from the handbook.
  • This is the chapter i've followed:
  • Writing an Image File to USB
  • of course i downloaded the '-memstick.img'-image.
  • And run. dd if=FreeBSD-10.3-RELEASE-i386-memstick.img of=/dev/sdk1 bs=1M conv=sync
  • Then i booted the USB on my laptop, and got this error: "Invalid partition table"... Nothing else.
  • Disappointing.
I've read some other people having the same error, selected MBR instead of GPT. I have no idea how to select Master Boot Record. Heard that some older laptops can't boot using GPT. But how can i select MBR?

This is a post, where someone has the same problem:

Any help is much appreciated.
jm0, try using dd(1) to write the FreeBSD installation image file to /dev/sdk, instead of /dev/sdk1. I'm guessing that /dev/sdk1 refers to an existing partition on your USB stick, instead of the entire USB stick itself.
The memstick image is supposed to be written directly on a memory stick overwriting any partition tables it might have. On a typical Linux system if the memory stick is sdb you do the following:

dd if=FreeBSD-10.3-RELEASE-i386-memstick.img of=/dev/sdb bs=1M conv=sync

Note, no number at the end of sdb to signify that the image is written on the whole disk starting from the first sector.
You guys hit the nail!
That actually fixed the problem. Lol.
Guess i learned something new today, 'ah that's what the numbers are for in the device-names sdb[n] :)

Thank you very very much, you saved the day!
Booted directly into the intalling process.