Trouble installing XFCE

tpg

New Member


Messages: 3

Hi, im new to this forum, and ive been trying this and that with FreeBSD for abit now, but it seems there are things that are still abit unclear to me which i dont understand..

Now the problem is, i have installed a clean FreeBSD version of 7.0 CURRENT as a X-user, so i do have the minimum stuff including X window, but when i try to install XFCE after "startx" i get a weird FTP error, this one: in X window

ERROR:FTP unable to get "link" no adress record
pkg_add:Unable to fetch "link" by URL

Now, i had this in the past with installing Gnome, installed the ports package collection at the next installation and it worked properly, but im wondering if there is any way to download/install things without getting the ports collection at all(at the installation, because i think its required for some programs). The reason why im asking about something which includes not installing the ports collection is because im trying to make a minimum system with as less programs and unrequired stuff as possible. Also i may have clicked on "install ports collection" with this installation, but i doubt that it did any good, because i only used the first .iso CD to install FreeBSD.

The command that i have been using to install XFCE is: pkg_add -r xfce4

It is the same command as i used to get Gnome, but it would be great if there is another way to get it, ive been looking arround trying to find how to do this, but maybe im just not looking good enough :)

I hope someone can help my confusion with this issue :D

Thanks!

EDIT: Also it may be possible that my internet isnt working, not sure how to check that.. but maybe its required to install some ports or something for the internet to work, im doing this on VMware, it should work.

EDIT2: ATM im installing another FreeBSD with ports collection(ftp this time, so no cd), will let you know if it works out :)
 

marius

Member

Reaction score: 17
Messages: 68

Welcome to the forum :)

I'm not sure I fully understand if you have or have not installed XFCE.

First, try to check if your internet connection is working. You can do this by pinging a known hostname.

Code:
ping google.com


You should see something like this:

PING google.com (72.14.205.100): 56 data bytes
64 bytes from 72.14.205.100: icmp_seq=0 ttl=237 time=135.290 ms
64 bytes from 72.14.205.100: icmp_seq=1 ttl=237 time=132.949 ms
64 bytes from 72.14.205.100: icmp_seq=2 ttl=237 time=134.585 ms

Another helpful command is "ifconfig", this is used to configure your interfaces, like network cards.

Code:
ifconfig


sis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 192.168.1.6 netmask 0xffffff00 broadcast 192.168.1.255
        ether 00:00:24:c4:81:20
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
sis1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 0.0.0.0 netmask 0xff000000 broadcast 0.255.255.255
        ether 00:00:24:c4:81:21
        media: Ethernet autoselect (none)
        status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
Here you can see that my network card sis0 is marked as UP and has been assigned the IP-address 192.168.1.6, while sis1 is down and have no IP assigned to it. You will probably not see sis0, but another name instead if you try the ifconfig command.

If you don't have an IP-address assigned, try to use "dhclient sis0", but remember to replace sis0 with the name of your network card.

The ports collection is located on the first CD. Ports and packages are not the same thing. Ports are installed by going to /usr/ports/something and typing "make install", while packages are installed by using "pkg_add -r something".

You will find answers to most of your questions in FreeBSD Handbook
 
OP
T

tpg

New Member


Messages: 3

Ok, it seems like almost everything is totally fine now, i installed FreeBSD again, but this time i installed the ports collection from the FTP and skipped the package request later in the installation

Now i have downloaded/installed XFCE and it works, also pinging works, so that means my internet works also(couldnt install or get XFCE without internet)

BUT, there is one problem still, which i had in Gnome also, im using VMware but i dont think VMware is the problem, my resolution is waaay too big at the moment, i have a 22 inch wide screen so its really big, i have to scroll most of the time.

Im not sure what to do about this, maybe installing my videocard drivers? But does that have any effect on a VMware OS?

When i try to change the resolution in XFCE i only see default resolution, and nothing else, is there any other way to change this?

Thanks!
 

marius

Member

Reaction score: 17
Messages: 68

It's possible that you have to install something called "vmware tools", at least it was called that back in the old days.

There should be a link on the bottom left of the vmware window.
 
OP
T

tpg

New Member


Messages: 3

marius said:
It's possible that you have to install something called "vmware tools", at least it was called that back in the old days.

There should be a link on the bottom left of the vmware window.
Hmm, it seems i already fixed the resolution, by changing it at the Display options to another resolution

Thanks thought! Everything works fine now!
 
Top