• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Torrent Server?

Beastie

Daemon

Thanks: 418
Messages: 2,085

#4
+1 for Transmission.

You can easily control it from any web browser using www/transmission-web. Or you can use transmission-remote (included in net-p2p/transmission-daemon) to control it from the shell/terminal emulator:
  • Unlimited download speed: transmission-remote -D
  • 100 KB/S download speed limit: transmission-remote -d100
  • Unlimited upload speed: transmission-remote -U
  • 50 KB/S upload speed limit: transmission-remote -u50
  • List all torrents (and their IDs/#): transmission-remote -l
  • Start torrent #37: transmission-remote -t37 -s
  • Stop torrent #52: transmission-remote -t52 -S
  • etc.

It's also available in separate GTK+-based (net-p2p/transmission-gtk2) and Qt-based (net-p2p/transmission-qt4) versions if you're more "point-and-click".

You can use either net-p2p/transmission-daemon (with www/transmission-web optionally) or any one of the graphical versions. The two are NOT compatible!
 

UNIXgod

Daemon

Thanks: 199
Messages: 1,089

#5
foldingstock said:
I use rtorrent + tmux for a similar application. Its not a daemon, but works well enough.
did the same for a long time with gnu/screen. I hear utorrent is a nice front end for rtorrent though I have never used it.

I can't imagine setting up a rc script for rtorrent would be much of a hassle either.
 

TomHsiung

Member

Thanks: 5
Messages: 74

#7
How to fix the reset (of settings.json) issue of transmission-daemon? Every time transmission service restarted, some settings in /usr/local/etc/transmission/home/settings.json was reset to defaults.

Tom
 

ekingston

Active Member

Thanks: 39
Messages: 144

#8
How to fix the reset (of settings.json) issue of transmission-daemon? Every time transmission service restarted, some settings in /usr/local/etc/transmission/home/settings.json was reset to defaults.

Tom
To avoid having your changes to settings.json get overwritten when Transmission restarts, follow these steps:

1) Shut down the Transmission daemon
2) Make your changes to settings.json
3) Start the transmission daemon
4) Don't do step 2 again until you have completed step 1

I think the first 3 of those steps is explained on the transmission website, but I'm at work. We aren't allowed to go to that website from the office. We might be downloading an unofficial version of Linux or something.
 

TomHsiung

Member

Thanks: 5
Messages: 74

#9
I did stop the transmission service before I edited the settings.json file. However, some settings in the settings.json file just had been reset to default after the transmission serviced being started again, including the privileges of the /usr/local/etc/transmission/home directory. It looks like some script reset the settings.

Tom
 

Duffyx

Member

Thanks: 8
Messages: 32

#10
TomHsiung, I would advise you to read a guide about "how to ask questions the smart way".
First of all, tell us what you have tried. Second, be more specific... "some settings were reset to default".

For your answer look at the rc script of transmission.
I think that adding transmission_chown="NO" to /etc/rc.conf should fix your problem.
 
Last edited: