Xfce Thunar times out while browsing network, issue happens with other file managers

bsduser2112

New Member


Messages: 9

I'm running Xfce on Freebsd stable-11 in a virtual machine and this issue just started happening recently after upgrading some ports on my desktop but I am not able to track down how to fix it. Hopefully, someone here can help me. I was able to browse the network and use the address bar to enter smb://ipaddress to go to the share I wanted in the past. Everything worked. However, now I am either receiving timeouts instead when browsing the network after some time or just no response from the file manager.

Obviously a port upgrade is the culprit but I don't know which port changed to cause the issue. I've tried other file managers as well such as pcmanfm and nautilus and they also don't work and simply just hang when browsing the network or entering a specific address for smb://.
I've also created a new virtual machine with the same desktop and the issue is still present.
I have another virtual machine with the same Xfce and stable-11 which I haven't updated ports on and it doesn't have this issue.

Can someone else confirm this is an issue. I've checked the Freebsd bug tracker and can't find any issue with respect to this. Any pointers or help to track down what changed and fix this issue would be greatly appreciated.

Thanks
 

k.jacker

Aspiring Daemon

Reaction score: 422
Messages: 723

You should first try to mount it manually and see what error messages you get like:
mount_smbfs -I ipadress-of-smb-server //user-on-smb-server@samba/path-on-server /local-mount-point/
man mount_smbfs(8)
 
OP
OP
B

bsduser2112

New Member


Messages: 9

I am able to mount it manually under a local mount point as you stated above and there are no errors upon mounting displayed. I can access the drive fine from the command line and do file operations under the command line. The command line is how i am getting around the problem at the moment. But the real issue is with any of the file managers Thunar or nautilus or pcmanfm. I used to be able to browse, access and use the network shares with the file manager but that doesn't seem to function anymore. Something has changed but I don't know what. I have an old virtual machine instance of Freebsd 11-stable i can boot in which the file manager works with network shares. I also have a new instance i created the other day of Freebsd 11-stable and the file manager simply does not work to access samba network shares. Most times it simply times out and sometimes offers the message Failed to open "/ on" . Obviously the workaround is to use the command line and it works there but it is an annoyance that it does not work as expected.
 

k.jacker

Aspiring Daemon

Reaction score: 422
Messages: 723

So even if you mount samba from the command line, you can't access it it Thunar? Then it should be a network problem?
Have you looked for logfiles in /var/log/samba? (not really sure about that...)
You could also check logfiles on the samba server.
Do you access samba via user/password authentication? Do you got asked for your password or did you provide it with the mount-command before it stopped working?
Do you use a credentials file?
 
OP
OP
B

bsduser2112

New Member


Messages: 9

You are indeed right! Yes I can access it through Thunar when I mount it manually from the command line. I was just not thinking when i replied last night and had a bit of a brain fart and just defaulted to using the command line to do file operations as a workaround when I discovered Thunar wasn't behaving like it used to. When it was plainly OBVIOUS i could just use the file manager once it was mounted to access it at the mount point. I'm just dumb. Thanks for that. I was just used to accessing my shares through thunar and having it automount it for me when i provided a username and password for the share once i clicked on it. That functionality is what seems to me has broken recently in Freebsd and don't know why it isn't working like it used to on my Xfce desktop. I have two different VM's of Freebsd and in an older VM that I haven't kept updated it works just by browsing with Thunar and giving it a username/password but in this new VM which is up to date it doesn't. I don't have a /var/log/samba on my filesystem so no help looking there. If I enter an address in the Thunar address bar like this: smb://ip-address it doesn't appear to do anything when I hit enter. Looking at the log file of the server I am connecting to shows only the attempts I make manually as connecting and mounting properly. No attempts show up when I try to mount it with Thunar on the server log. So something with Thunar or one of its dependencies is probably at fault.

I'm not that sophisticated in troubleshooting weird stuff like this, so I guess I will just live with mounting my shares through the command line. Thanks for your help.
 

k.jacker

Aspiring Daemon

Reaction score: 422
Messages: 723

Yeah, troubleshooting things that sit upon Xorg isn't easy. It's hard to understand what's going on in the background.
One thing that's positive when you mount it manually is, you get better transfer speeds.
About a year ago or so when using XFCE I noticed bad performance when accessing Samba from Thunar.
So I did some speedtesting with lots of small files as well as big video files with Thunar, PacmanFM and the Gnome filemanager if I remember that right. So I tried mounting manually and also let the filemanagers mount my Samba shares.
And guess what? Thunar was the worst when it was uses to mount Samba (as low as 30MB/s for video files). The other filemanagers wheren't much better.
When I mounted Samba manually and than used Thunar and the other filemanagers to access the Samba share gave much better results (then above 100MB/s for video files in Thunar).
Not sure if that's still the case and I was a little stupid, too, as I did not check what mount-options the filemanagers actually used in comparison to my manually mounting.
I would stick with mounting Samba manually (you could create an alias) or from /etc/fstab! :)
 

mpeterma

New Member

Reaction score: 3
Messages: 12

Hello bsduser 2112,

I can confirm that this issue also occured recently on my workstation.
Anyway - looks like you have the key for further analysis. Can you please
share the output of "pkg info" from both VM instances (the one where it
still works and the one where it stopped working)? With this data it should
be possible to isolate candidates for deeper inspection.

Thanks in advance & best regards,
Matthias
 
Top