Solved The right way to define a name for epairs

Hi,

Why when I create an "epair" with a specific name there is only one segment using that given name while the other segment use the default name like nothing happened ?
I think there is an obvious reason for that or probably one way to do it correctly, but I can't see which one exactly.

Bash:
$ ifconfig epair create name pr_
pr_: flags=8862<BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=8<VLAN_MTU>
    ether 02:f0:dd:2f:32:0a
    groups: epair
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
epair3b: flags=8862<BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=8<VLAN_MTU>
    ether 02:f0:dd:2f:32:0b
    groups: epair
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

Both segments are from the pair if we refer to their MAC address but they are named differently.
How can I fix it ?

Thank you in advance :)
 

zirias@

Developer
I never thought about custom names for this, but I assume you can't specify a name for both ends because ifconfig(8) never expects that create would create more than one interface.

Still, renaming works just fine, e.g. in your example ifconfig epair3b name pr_b or whatever you wanted....
 
I never thought I could do it in 2 steps, one segment at the time ... it never crossed my mind :rolleyes:
That's clever and dead simple , thank you zirias@
 
Top