• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

The Laptop/Notebook thread

PegMonster

New Member

Thanks: 1
Messages: 2

#1
One of the most daunting tasks for installing FreeBSD is making sure you have the right hardware for the job.
This is particularly true with laptops/notebooks. They are generally slapped together with cheap or windows friendly hardware with no guarantee for successfully installing FreeBSD. This can be a very pricey gamble.

The reason for this thread is to get feedback from users who have installed FreeBSD on their laptop/notebook to make it easier for those who are looking to do the same.

I know there is already the Laptop Compatibility list (here), but many models are long outdated and the results tend to be vague in description, if they have any at all.

Please include make, model, what is and isn't working out of the box, how you overcame any problems if you managed to do so, and anything else you would like to add.

Thanks guys.

J
 

PegMonster

New Member

Thanks: 1
Messages: 2

#2
I have a Compaq V3230AU.

PROCESSOR – AMD Turion 64 X2 Dual Core Mobile Technology TL-50 1.6GHz
MEMORY - 1024MB DDR2 (2 Dimms)
HARD DRIVE - 80GB 5400rpm
OPTICAL DRIVE - SuperMulti 8X DVD±RW with Double Layer support
COLOUR DISPLAY - 14.1" WXGA High-Definition BrightView Widescreen Display
VIDEO – nVidia GeForce Go 6150
TV-OUT PORT – S-Video Output
LAN - Integrated 10/100 LAN; Broadcom 802.11a/b/g
MODEM - High speed 56K modem
SPEAKERS - Altec Lansing speakers
CARD READER – Ricoh 5-in-1
USB PORT - 3 USB 2.0 ports
EXPRESS CARD SLOT - ExpressCard54 slot (supports both 34 and 54 form factors)
IEEE1394 PORT - Yes
INFRA-RED PORT – Consumer IR
BLUE TOOTH - Yes
BIOS - Phoenix

Unfortunately it wont even boot FreeBSD. It fails before making it to the beastie menu with btx halt errors. I have tried updating the BIOS and disabling acpi, but still no go.
I've searched high and low for solutions, but so far no luck.

J
 

ripcurl

New Member

Thanks: 1
Messages: 5

#4
Dell Inspiron 1501

Code:
Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.1-STABLE #1: Mon Jan 26 23:28:55 MYT 2009
    [email]root@matrix.bsd.my[/email]:/usr/obj/usr/src/sys/INSP_1501
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 X2 Mobile Technology TL-50 (1596.01-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40f82  Stepping = 2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
  Cores per package: 2
real memory  = 2011627520 (1918 MB)
avail memory = 1963073536 (1872 MB)
ACPI APIC Table: <PTLTD  	 APIC  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 2.1> irqs 0-23 on motherboard
netsmb_dev: loaded
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <DELL M08    > on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
unknown: I/O range not supported
acpi0: reservation of 0, 1000 (3) failed
ACPI HPET table warning: Sequence is non-zero (2)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x14> port 0x62,0x66 on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x9000-0x90ff mem 0xc8000000-0xcfffffff,0xc0100000-0xc010ffff irq 17 at device 5.0 on pci1
acpi_video0: <ACPI video extension> on vgapci0
drm0: <ATI Radeon RS485 XPRESS 1100 IGP> on vgapci0
vgapci0: child drm0 requested pci_enable_busmaster
info: [drm] Initialized radeon 1.29.0 20080613
pcib2: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci5: <ACPI PCI bus> on pcib3
ath0: <Atheros 5424/2424> mem 0xc0200000-0xc020ffff irq 18 at device 0.0 on pci5
ath0: [ITHREAD]
ath0: WARNING: using obsoleted if_watchdog interface
ath0: Ethernet address: 00:16:cb:b8:99:88
ath0: mac 10.3 phy 6.1 radio 10.2
atapci0: <ATI IXP600 SATA300 controller> port 0x8438-0x843f,0x8454-0x8457,0x8430-0x8437,0x8450-0x8453,0x8400-0x840f mem 0xc0004000-0xc00043ff irq 22 at device 18.0 on pci0
atapci0: [ITHREAD]
atapci0: AHCI Version 01.10 controller with 4 ports detected
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci0
ata5: [ITHREAD]
ohci0: <OHCI (generic) USB controller> mem 0xc0005000-0xc0005fff irq 16 at device 19.0 on pci0
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xc0006000-0xc0006fff irq 17 at device 19.1 on pci0
ohci1: [GIANT-LOCKED]
ohci1: [ITHREAD]
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
ohci2: <OHCI (generic) USB controller> mem 0xc0007000-0xc0007fff irq 18 at device 19.2 on pci0
ohci2: [GIANT-LOCKED]
ohci2: [ITHREAD]
usb2: OHCI version 1.0, legacy support
usb2: <OHCI (generic) USB controller> on ohci2
usb2: USB revision 1.0
uhub2: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
ohci3: <OHCI (generic) USB controller> mem 0xc0008000-0xc0008fff irq 17 at device 19.3 on pci0
ohci3: [GIANT-LOCKED]
ohci3: [ITHREAD]
usb3: OHCI version 1.0, legacy support
usb3: <OHCI (generic) USB controller> on ohci3
usb3: USB revision 1.0
uhub3: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
ohci4: <OHCI (generic) USB controller> mem 0xc0009000-0xc0009fff irq 18 at device 19.4 on pci0
ohci4: [GIANT-LOCKED]
ohci4: [ITHREAD]
usb4: OHCI version 1.0, legacy support
usb4: <OHCI (generic) USB controller> on ohci4
usb4: USB revision 1.0
uhub4: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb4
uhub4: 2 ports with 2 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xc0004400-0xc00044ff irq 19 at device 19.5 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb5: EHCI version 1.0
usb5: companion controllers, 2 ports each: usb0 usb1 usb2 usb3 usb4
usb5: <EHCI (generic) USB 2.0 controller> on ehci0
usb5: USB revision 2.0
uhub5: <ATI EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb5
uhub5: 10 ports with 10 removable, self powered
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci1: <ATI IXP600 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8420-0x842f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
hdac0: <ATI SB600 High Definition Audio Controller> mem 0xc0000000-0xc0003fff irq 16 at device 20.2 on pci0
hdac0: HDA Driver Revision: 20090113_0125
hdac0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib4: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci8: <ACPI PCI bus> on pcib4
bfe0: <Broadcom BCM4401-B0 Fast Ethernet> mem 0xc0300000-0xc0301fff irq 21 at device 0.0 on pci8
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> PHY 1 on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: Ethernet address: 00:15:c5:cc:d2:4c
bfe0: [ITHREAD]
sdhci0: <RICOH R5C822 SD> mem 0xc0302000-0xc03020ff irq 20 at device 1.0 on pci8
sdhci0: 1 slot(s) allocated
sdhci0: [ITHREAD]
pci8: <base peripheral> at device 1.1 (no driver attached)
acpi_button1: <Sleep Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model Synaptics Touchpad, device ID 0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
powernow0: <PowerNow! K8> on cpu0
cpu1: <ACPI CPU> on acpi0
powernow1: <PowerNow! K8> on cpu1
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xcdfff pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
acd0: DVDR <TSSTcorp DVD+/-RW TS-L632H/D400> at ata0-master UDMA33
ad4: 57231MB <TOSHIBA MK6034GSX AH101D> at ata2-master SATA150
hdac0: HDA Codec #0: Conexant (Unknown)
hdac0: HDA Codec #1: Sigmatel STAC9220
pcm0: <HDA Sigmatel STAC9220 PCM #0 Analog> at cad 1 nid 1 on hdac0
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad4s2a
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 
cd0 at ata0 bus 0 target 0 lun 0
cd0: <TSSTcorp DVD+-RW TS-L632H D400> Removable CD-ROM SCSI-0 device 
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Initially this laptop came with a Broadcom wireless. I used it for awhile with the ndis driver and decided to replace it with an Atheros mini-pcie card.

Haven't tried getting the builtin winmodem to work though, but it's ok since I don't use it.

After upgrading Xorg to 7.4, DRI works.
 

ufonpu

New Member


Messages: 4

#5
I have a similar hardware with you and when I reboot after install FreeBSD7.1 i386 it got panic saying "acpi autoload failed,no such file or directory ...btx halted." and I didn't have this problem solved yet.
If you have any info about this problem please info me as quickly.
Thx.
 

fronclynne

Daemon

Thanks: 175
Messages: 1,297

#6
Toshiba L305D-S5895 (turion x2, ati radeon (drm0: <ATI Radeon RS690 X1270 IGP> on vgapci0) (using x11-drivers/xf86-video-radeonhd-devel) FreeBSD 7.1-STABLE amd64.
Going to have to patch to get the ath wireless working, I suppose.

N.B.: powerd and this lapbrick do NOT play nice (is this a known problem with Toshibas and I'm ig'n'runt?).

No suspend/hibernate (yeah, I know) . . . when the battery runs down it goes "click" and that is that.

The touchpad is really poorly situated (if I may use such a word to the exclusion of "located" or "designed", since I don't think they did that with it), but it actually works well, when I want to use it, but no [redacted] middle button. Do they know this is not 1986?

Otherwise, quite fast and the sound card does all that noisy stuff he's s'posed to.
 

ripcurl

New Member

Thanks: 1
Messages: 5

#7
ufonpu said:
I have a similar hardware with you and when I reboot after install FreeBSD7.1 i386 it got panic saying "acpi autoload failed,no such file or directory ...btx halted." and I didn't have this problem solved yet.
I don't have this problem. I'd suggest you try adding this to /boot/loader.conf

module_path="/boot/kernel;/boot/modules"
 

fronclynne

Daemon

Thanks: 175
Messages: 1,297

#9
ufonpu said:
But I can't even log in the systerm.How can I edit the file?
LiveFS CD?
PCBSD?
enter it at the loader prompt?
There must be a few other methods I'm not thinkin' of.
 

ripcurl

New Member

Thanks: 1
Messages: 5

#10
fronclynne said:
LiveFS CD?
PCBSD?
enter it at the loader prompt?
There must be a few other methods I'm not thinkin' of.
Yes LiveCD, then enter Fixit mode, mount your / and edit /boot/loader.conf.
 

trev

Aspiring Daemon

Thanks: 88
Messages: 536

#11
Eee PC 701 (2G memory, 4G SSD, 16G SDHC)

* CPU: Intel Celeron M 353 900MHz processor (underclocked to 630.07-MHz 686-class CPU)
* WLAN: Atheros 5424/2424 - ath(4)
* Ethernet: Attansic L2 FastEthernet - ae(4)
* Function Keys: acpi_asus(4), acpi_video(4)
* Touchpad: synaptics (X11)
* Hardware monitoring: eeemon(4)
* Audio: Realtek ALC6628 Hi-Definition Audio - snd_hda(4)
* WebCam: unsupported

Works brilliantly except that running FreeBSD off the 16G SDHC card means that I cannot put it to sleep and wake it up again, because putting it to sleep disconnects power from the USB bus which in turn disconnects the SDHC card reader and FreeBSD panics on awakening because it cannot find its file system.

(I need XP on the SSD for my wife's photography cataloguing software).
 

fronclynne

Daemon

Thanks: 175
Messages: 1,297

#12
fronclynne said:
Toshiba L305D-S5895 (turion x2, ati radeon (drm0: <ATI Radeon RS690 X1270 IGP> on vgapci0) (using x11-drivers/xf86-video-radeonhd-devel) FreeBSD 7.1-STABLE amd64.
Going to have to patch to get the ath wireless working, I suppose.
Hoorj! The patch here:
http://people.freebsd.org/~sam/
applies cleanly to 7-STABLE, and (more importantly) ath0 does what it should.
 

mickey

Well-Known Member

Thanks: 52
Messages: 359

#13
IBM ThinkPad 600 (2645-450):

- Pentium II 300 MHz CPU
- 288 MB Ram
- 5 GB HDD
- Atheros 5212 based cardbus wireless adapter

This machine runs more or less successfully 7.1-RELEASE-p2. Here's what's working or not:

  1. The ACPI DSDT on this machine has a broken PCI IRQ routing, which requires manually fixing the DSDT code and booting with the modified DSDT.
  2. An atheros based wireless cardbus adapter only works with a hacked kernel.
  3. The ath driver every once in a while leads to interrupt storm issues, but these seem to have no notable effect on network connectivity.
  4. ACPI sleep is totally borken, i.e. suspend to death.
  5. Xorg 7.4 with server 1.5.3_5,1 runs successfully with a 1024x768 resolution in 16 bpp.
  6. When using hald with cardbus atheros adapter, requires a faked /usr/sbin/dumpcis, otherwise the ath driver goes mad when hald invokes dumpcis upon the active cardbus adapter.

IBM ThinkPad T30:

- Pentium 4-M 2GHz CPU
- 512MB RAM
- 60GB HDD
- Atheros 5212 based mini-PCI wireless adapter.

This machine successfully runs 7.1-RELEASE-p2.

  1. The sysctl values for the ACPI thermal subsystem needed some finetuning, otherwise the machine would eventually overheat and shutdown when compiling larger stuff.
  2. For ACPI suspend/resume to work correctly one needs to use the radeontool from the ports and tweak rc.suspend/rc.resume in order to have the LCD backlight turned off when suspending.
  3. Suspend/Resume still works not quite reliably.
  4. Xorg 7.4 with server 1.5.3_5,1 runs successfully with a 1024x768 resolution in 24 bpp.
  5. Runs Gnome 2.24 relatively smoothly.
  6. IBM has put a whitelist of mini-PCI adapters into the BIOS, so installing a 'non-authorized' mini-PCI card requires evil BIOS hacking to get rid of the error/warning messages during POST.
  7. As with the ThinkPad 600, this machine also experiences interrupt storm issues with the ath driver, which can not be solved by changing IRQs in BIOS (tried to no avail).
 

vermaden

Son of Beastie

Thanks: 902
Messages: 2,578

#14
Dell Latitude D630 / E6400 Power Consumption Comparison

Code:
[B][U]Dell Latitude D630 power consumption (+/- 0.5W)[/U][/B]
screen MAX + wifi ON ---> 22.5W
screen MAX + wifi OFF --> 21.5W
screen MIN + wifi ON ---> 16.5W
screen MIN + wifi OFF --> 15.5W
screen OFF + wifi ON ---> 12.5W
screen OFF + wifi OFF --> 11.5W
Code:
[B][U]Dell Latitude E6400 power consumption (+/- 0.5W)[/U][/B]
screen MAX + wifi ON ---> 17.5W [color="#00ff00"](-5)[/color]
screen MAX + wifi OFF --> 16.5W [color="#00ff00"](-5)[/color]
screen MIN + wifi ON ---> 13.5W [color="Lime"](-3)[/color]
screen MIN + wifi OFF --> 12.5W [color="#00ff00"](-3)[/color]
screen OFF + wifi ON ---> 11.5W [color="#00ff00"](-1)[/color]
screen OFF + wifi OFF -->  9.5W [color="#00ff00"](-2)[/color]
Code:
[B]      D630              E6400[/B]
cpu   T7300 (65nm)      P8400 (45nm)
ram   2 x 1GB DDR2 667  2 x 1GB DDR2 800
gfx   X3100 (90nm)      x4500 (65nm)
scr   CCFL WXGA+        LED WXGA+
wir   3945              5300
hdd   seagate 7200.2    seagate 7200.3
bay   DVD-RW            DVD-RW
 

rod

New Member


Messages: 10

#15
this post should be clasified as "important"

nice work guys.

btw, i search about dell laptops, but i didn't get any info about a vostro a840, if anyone knows about some page dedicated to dell laptops it would be helpful

cheers
 

sossego

Retired from the forums

Thanks: 142
Messages: 1,561

#16
If laptop is working under NetBSD, what is needed for it to work under FreeBSD?
 

Oko

Daemon

Thanks: 594
Messages: 1,518

#18
ripcurl said:
Hi there,

You could try booting FreeSBIE on it and see if it detects your hardware.
That is a bad advice. FreeSBIE is dead project and the last release was based on FreeBSD 6.2. There was one major release and many minor releases since then so the hardware support has improved a great deal. However FreeSBIE tools should be still in ports so theoretically one should be able to build FreeBSD LiveCD from 7.2. There is no alive LiveCD project based on FreeBSD to my knowledge at this time. The last LiveCD project TrueBSD seems died about half a year ago.

Since USB sticks are so cheap today and many BIOS-es support booting from USB device one could do honest installation on USB(SCSI HDD) and use that to test the hardware.
 

sossego

Retired from the forums

Thanks: 142
Messages: 1,561

#19
Is there a howto for usb booting as there exists for linux live usb sticks or is it touch and go.
I'd also have to edit the boot defaults to use acpi, control the hardware, etc.
FreeSBIE may be the way to go.
 

tiko

Member

Thanks: 2
Messages: 32

#20
My laptop is rather old by today's standards, but I'm quite pleased with its capabilities under FreeBSD.

I have a stock HP/Compaq NC6000 business laptop with the following hardware:

Pentium M 1.6Ghz
2GB PC2700
60GB IDE
ATI Radeon Mobility 9600
Gigabit Broadcom LAN using gbe driver
Intel wireless using iwi driver (This needs to be updated manually: see this link.)
Strangely enough, under X, the driver does not crap out. It happened to me only when using the laptop as a terminal.

Running 7.2-Release

Everything on this laptop functions as it should from a users standpoint. The only thing I had to "tweak" was enabling hald for Xorg 7.4 to recognize the touchpad. Battery time is about 2.5 hours, compared to about 1.25 hours with XP.

I have xfce4 and KDE 3.5 successfully installed and functioning properly. Even have flash9 working for Firefox. Overall, very pleased with FreeBSD and this particular laptop.
 

Eponasoft

Active Member

Thanks: 10
Messages: 218

#21
I'm using an Acer Aspire 3680 without too many problems with FreeBSD 7.2 STABLE. Only issue has been the ACPI, which is easily solved by disabling it, and even then, the only issue it created with it on was a nonworking msk0.
 

empty

Member

Thanks: 1
Messages: 28

#23
New laptop, suggestions!

Hello everyone.

What laptop should i purchase that FreeBSD will run smoothly on?
Thinking mostly on, wlan,sound and graphics?

Anybody have any suggestions on a netbook? (Around 10" monitor)

Best Regards
empty
 

vermaden

Son of Beastie

Thanks: 902
Messages: 2,578

#24
For laptop, its simple: Dell Latitude or IBM/Lenovo ThinkPad.

Personally I have Dell Latitude D630 with Intel X3100 and everything works, others reported the same for R60/R61/T60/T61 ThinkPads. You may also consider older T40/T41/T42/T43 and D600/D610.

As for netbook, better get Dell D430 or HP 2510p, both have about dual core @ 1.2GHz / 2GB RAM / 12" 1280x800, HP 2510p even have the DVD-RW.

I would not look for netbooks. 12 is imho the smalles size to comfortable do anything.

The only netbook I can recommend are Atom Z-series based, but the Puolsbo chipset (with graphics from PowerVR instead of Intel, yes they call it Intel GMA 500, but its created by PowerVR), does not have support in Intel driver, do you end up with 2D without any accerlration.
 

kano

Member

Thanks: 4
Messages: 23

#25
I have an Acer Aspire One netbook, and everything works out of the box with 8.0. Installed with the 8.0-BETA2 usb image.

Some stats;
10" screen, 1.6GHz Intel Atom processor, 1gb ram, 160gb hd, Intel 945GM graphics, wifi works with ath driver and ethernet with alc driver in 8. I ended up paying less than $300 for it at walmart, so I'm quite happy that everything is supported. :)

Small keyboard takes a bit getting used to, but after that I don't mind it. I use openbox and generally have a workspace with a full screen urxvt+screen terminal and another with firefox using the vimperator extension. The small screen doesn't seem to matter when you know how to utilize it. ;)