Tell me about IPXrouted

DenisVS

Member

Thanks: 6
Messages: 23

#1
Since 11.1 had been installed, I encountered new messages at boot.
Code:
/etc/rc: WARNING: run_rc_command: cannot run /usr/sbin/IPXrouted
In my rc.conf(5) I did not find remarks about it
Date at the bottom line: FreeBSD 11.1-STABLE December 17, 2017
But online manual v.8.0 contains this point.
More over, there are 3 rcvars
ipxgateway_enable
(bool)If set to ``YES'', enable the routing of IPX traffic.

ipxrouted_enable
(bool)If set to ``YES'', run the IPXrouted(8)daemon at sys-
tem boot time.

ipxrouted_flags
(str) If ipxrouted_enable is set to ``YES'', these arethe
flags to pass to the IPXrouted(8) daemon.

What should I do and do I need this?
 

ShelLuser

Son of Beastie

Thanks: 1,576
Messages: 3,420

#3
So you're running a STABLE release? That's basically a developer snapshot meaning that anything can happen in there, it's not necessarily stable. I'm running 11.1 release and well, if you check /etc/defaults/rc.conf you'll notice that there's nothing regarding IPX in there, let alone any daemons.

And yes, IPX support was dropped ever since version 11 got released so at best this is merely a left over which suddenly popped up. But it's not something happening on FreeBSD by default.

(edit)

So my suggestion would be to remove any IPX related entries from /etc/rc.conf because they won't be of much use anyway.
 
OP
OP
DenisVS

DenisVS

Member

Thanks: 6
Messages: 23

#4
If i understood correctly, i just should ignore this message?
In my rc.conf was nothing about ipx.
 

ShelLuser

Son of Beastie

Thanks: 1,576
Messages: 3,420

#5
If i understood correctly, i just should ignore this message?
In my rc.conf was nothing about ipx.
You can probably just ignore it, however.. do be careful because this is not normal behavior so it could be an indication for other problems.

You might also want to check /etc/crontab and/or /var/cron/tabs just to be sure there's nothing IPX related mentioned there. (theoretically it is possible to set up a crontab which starts stuff during boot. Somewhat uncommon, but not impossible).
 
OP
OP
DenisVS

DenisVS

Member

Thanks: 6
Messages: 23

#6
Putting this lines into my /etc/rc.conf solved this issue:
Bash:
ipxgateway_enable="NO"             # Set to YES to enable IPX routing.
ipxrouted_enable="NO"              # Set to YES to run the IPX routing daemon.
ipxrouted_flags=""         # Flags for IPX routing daemon.
Obviosly the ancient code afterwards is here.
 

ShelLuser

Son of Beastie

Thanks: 1,576
Messages: 3,420

#7
What I gather from this page it seems to be specific for STABLE. If you want to avoid issues such as these then it helps to stick with releases.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,606
Messages: 28,131

#8
You need to run mergemaster(8) to clean up deprecated rc(8) scripts. Apparently some of the /etc/ files from the FreeBSD 8.x era are still lingering on your system.
 
Top