• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Teamspeak 3

tiko

Member

Thanks: 2
Messages: 32

#1
Hello all,

I'm wondering if anyone has any suggestions for using the Teamspeak 3 linux x86 client with FreeBSD (amd64). I've tried the win32 client with the wine packages from http://people.freebsd.org/~ivoras/wine/ without success and the early linux beta clients work as expected, however, they cannot connect to the recent server betas likely due to protocol changes.

The output from the most recent linux client (beta 26 at the time of writing) is as follows:
Code:
$ bash ts3client_runscript.sh
2010-08-20 12:38:34.510229|INFO    |MPSingleton   |   | Detected local codeset to be: ANSI_X3.4-1968
2010-08-20 12:38:34.511455|INFO    |              |   | Logging started, clientlib version: 3.0.0-beta26 [Build: 12040]
2010-08-20 12:38:34.600606|WARNING |SCHandler     |  1| Error during bind
2010-08-20 12:38:34.692677|CRITICAL|EvtConverter  |   | Error spawning server connecting handler
I realize this is proprietary stuff and there probably isn't much I can do, but I thought I'd give it a shot and see if anyone had any suggestions on getting around this. It might also be beneficial to mention that I'm using audio/oss for sound rather than the sound kernel module, but this has not had any effect on the client, as I've tried both. OSS has actually gotten me further into using the win32 client in wine than with sound.ko loaded, but it fails at connecting.

-tiko
FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:36:49 UTC 2010 root@mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC amd64


Edit: I've found a better solution, /usr/ports/audio/mumble using the server /usr/ports/audio/murmur. The few people using Teamspeak with me were willing to change over.