Tagged by udev as: mouse

PaddyMac

Member

Reaction score: 9
Messages: 34

I'm excited about the kernel evdev support in FreeBSD and the prospect of having a more plug'n'play experience with peripherals like USB input devices. But things aren't working as expected.

I have tried two laptops where the touchpad works to move the mouse cursor, and the buttons for the pad work, but features like tap to click or two-finger scrolling do not. KDE Plasma's Touchpad settings says that a touchpad is not detected.

I also have three USB game controllers I've tried to get working. I have a PDP Xbox One controller, a Microsoft Xbox 360 controller, and a Logitech Dual Action controller. I've tried using webcamd, and it sets up the controllers with /dev/input/event7 devices, but in KDE the only thing that happens is that the left joystick moves the mouse cursor. I also tried the iichid port. Without need of webcamd, it will also create /dev/input/event* devices for the USB game controllers. But with it, I get the same behavior: KDE doesn't recognize that a joystick is present, and the left joystick moves the mouse cursor.

But I noticed something interesting in /var/log/Xorg.0.log which makes me believe that the touchpad and USB game controller issues are related. For all of those device entries, there is a line which says "tagged by udev as: mouse". The other devices like the keyboard are tagged correctly.

Udev is capable of tagging peripherals as touchpads or joysticks as well as keyboards, mice, touchscreens, and so on. So apparently there is a problem with udev's detection of these kinds of devices on FreeBSD. Unless there's something else involved that I'm unaware of, I'm suspecting a problem with libudev-devd (unless there is something more fundamental wrong with the kernel's evdev support).

Is there a way to force udev to tag certain devices in a certain way, overriding autodetection? I suspect that my touchpads and USB game controllers would work as expected if they were correctly tagged by udev.
 

phalange

Active Member

Reaction score: 53
Messages: 138

I had this issue, but installing xf86-input-evdev and xf86-input-synaptics

and then loading synaptics with

Code:
/boot/loader.conf
hw.psm.synaptics_support="1"
hw.psm.trackpoint_support="1"


I found it was auto-detected correctly. I don't know your laptop, but the trackpoint part is ThinkPad and may not be applicable.

The USB game controller you might get more attention in Multimedia/Games, and there are some previous threads like Thread 431425
 
Top