Solved Switch between ATI and VESA drivers?

sidetone

Daemon

Reaction score: 385
Messages: 1,071

My video hardware is in the APU, and it is ATI R7. How would I disable ATI hardware, and use VESA, or my supported (Radeon) videocard? (which my supported videocard doesn't show in dmesg output)

I unset the ATI driver option in xorg-drivers, and tinkering with the BIOS settings, but I got a blank screen with trying to use XDM and xorg. Would I need a specific xorg configuration file, and how would I do that if that was the case?

If I absolutely have to, I can switch out the APU/CPU.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 385
Messages: 1,071

This worked. The Radeon drivers from the card didn't show up in dmesg | grep -i radeon, until I adjusted the xorg.conf file. I had to include BusID from the output of pciconf -lv | grep -B3 display, and was able to use the Radeon driver for the card.

I had already switched the R7 APU to an APU that used generic (unspecified) Radeon hardware, before reading this. The other APU changed to an R5 in the other motherboard. Perhaps I'll see how that one works.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 385
Messages: 1,071

How would I select HDMI audio from the PCIe card when the full device doesn't show up in dmesg? Only the motherboard's HDMI audio information shows here. From the above I got the pci to show, as similarly suggested for video. pciconf -lv | grep -B3 multimedia.
Code:
hdac0@pci 0:1:0:1:   class=0x040300 card=0xaa90174b chip=0xaa901002 rev=0x00 hdr=0x00
vendor = 'Advanced Micro Devices [AMD] nee ATI'
device = 'Turks/Whistler HDMI Audio [Radeon HD 6000 Series]'
class = multimedia
dmesg | grep hdac turns up
Code:
hdac0: <ATI RV930 HDA Controller> mem 0xfea40000-0xfea43fff irq 19 at device 0.1 on pci 1
hdacc0: <ATI R6xx HDA CODEC> at cad 0 on hdac0
dmesg | grep HDMI
Code:
pcm0: <ATI R6xx (HDMI)> at nid 3 on hdaa0
info: [drm] HDMI-A-1
info: [drm] Connector HDMI-A-1: get mode from tunables:
info: [drm]  - kern.vt.fb.modes.HDMI-A-1
From this, both hardware shows up, but only the hardware motherboard shows up for sound (pcm).

cat /dev/sndstat | grep HDMIturns up
Code:
pcm0: <ATI R6xx (HDMI)> (play) default
Which has only the HDMI out on the motherboard, and not the ATI card.

It wasn't in the man page, but I'm actively searching the internet for the xorg conf file and audio. I'll update if I find something.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 385
Messages: 1,071

Ok. I got HDMI sound to work on my card, without configuring files. I disabled on-board integrated graphics, and I set it to IGD video (Sets the onboard graphics as the first display). (It seems counter-intuitive, but these are the BIOS options). This while, plugging the HDMI cable to the video card instead of the motherboard's.

dmesg | grep HDMI displays:
Code:
pcm0: <ATI R6xx (HDMI)> at nid 3 on hdaa0
pcm0: <ATI R6xx (HDMI)> at nid 3 on hdaa0
Yes, it's displayed twice.

cat /dev/sndstat | grep HDMI displays, still:
Code:
pcm0: <ATI R6xx (HDMI)> (play) default
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 385
Messages: 1,071

How would I disable VESA, in favor of ATI on the console, without having Xorg running? Would it be through /boot/loader.conf? It seems that loading ATI drivers through there hangs up the operating system. The only way I could figure out how to play music from HDMI output on the display console, is to switch display terminals (ctrl-alt-F#) from Xorg. To elaborate, kldstat only shows my Radeon drivers when Xorg is running. It is out of curiosity, how this could be done, to choose the driver, in this case to play sound out of HDMI, without having Xorg running. Is this possible to do? There's no urgency and expentency for this, but if possible, it would be nice to know about.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 385
Messages: 1,071

rc.conf:
Code:
kld_list="radeonkms"
make.conf:
Code:
OPTIONS_SET=ATI
OPTIONS_UNSET=VESA
Are what I have now.
 
Top