Sway and Wayland

shkhln

Son of Beastie

Reaction score: 1,167
Messages: 2,557

Better to begin with the primarily recommended module, than with the module that's intended for problem cases.
You were already told which way is the correct way. Multiple times. By different people. Either buy an Nvidia card and verify it yourself or don't bother.
 
Last edited by a moderator:

grahamperrin

Beastie's Twin

Reaction score: 1,664
Messages: 5,024

i'm actually using an laptop where the main gpu is an Nvidia GTX 1050 Mobile

PizdeX if it helps, various hardware probes show use of nvidia (the primarily recommended module) for GP107M [GeForce GTX 1050 Ti Mobile].

In chronological order:
If GeForce GTX 1050 Ti Mobile (probed) is significantly different from GTX 1050 Mobile (yours): sorry, this was not previously explained to me. A few months have passed since I used FreeBSD on a notebook with NVIDIA graphics.

The maintainer of x11/nvidia-driver very recently wrote:

It's all thoroughly documented in the x11/nvidia-driver/files/pkg-message.in, …

A highlighted view of the package message, as it appears in FreshPorts:

1642703570927.png
 
Last edited:

shkhln

Son of Beastie

Reaction score: 1,167
Messages: 2,557

I'd suggest taking that issue to the maintainer instead of posting misinformation everywhere. (And, no, your massive link dumps are never helpful. They might be well intended, but that doesn't make them any less confusing.)
 

grahamperrin

Beastie's Twin

Reaction score: 1,664
Messages: 5,024

… something like KDE on wayland 𡀦… - Add procfs to /etc/fstab

Incidentally, from the KDE Community Wiki:

We're advised that KDE software should – already – use libprocstat or another FreeBSD API; that proc is no longer a requirement.

Maybe required for other things, but technically not for KDE Plasma. If you become aware of any exception, please let us know. Thanks.

procfs(5)

libprocstat(3)
 

r2com

Member

Reaction score: 5
Messages: 85

alright so now I wanna try this swaywm and stumbled upon this forum, after trying as far as I can, so far I got error after running "sway" "Found 0 GPUs"
any ideas now? I have Intel® HD Graphics 4600 in that machine

and bigger question is..is it actually worth it? I saw someone on this thread saying that x11 is used in one or another way even with this setup... anyway, so is this experiment technically will do any better for me?
because if not id rather not continue and use awesomewm
 

Alain De Vos

Son of Beastie

Reaction score: 995
Messages: 3,073

Sway is not mature, it has some bugs.
But i used sway in the past and it is almost like i3
Here is my start script,
Code:
#!/usr/local/bin/zsh
export XDG_SESSION_TYPE=wayland
export GDK_BACKEND=wayland
export QT_QPA_PLATFORM=wayland
export SDL_VIDEODRIVER=wayland
export CLUTTER_BACKEND=wayland
export BEMENU_BACKEND=wayland
export WM=sway
export QT_QPA_PLATFORMTHEME="qt5ct"
export XKB_DEFAULT_LAYOUT="be(nodeadkeys)"
export XKB_DEFAULT_RULES=evdev
export XDG_RUNTIME_DIR=/home/x/TMP
exec seatd-launch sway

labwc works also good.
 
Top