Other Subversion weirdness

Have a small repo in the home folder that I've not touched in months.

Try to do 'svn status' - svn core dumps with 'out of memory' error. Try svnadmin verify /path/to/repo. Same error with core dump. Ditto for 'svnlook'.

svnadmin verify /path/to/repo
libsvn: Out of memory - terminating application.

So I 'cp -R' the whole repo to a flash drive. Run svnlook tree /flashdrive/repo. This works. Run svnadmin verify /flashdrive/repo on the flash drive copy. Also works.

svnadmin verify /flashdrive/repo
* Verifying metadata at revision 0 ...
* Verifying repository metadata ...
* Verifying metadata at revision 17 ...
* Verifying metadata at revision 65 ...
* Verifying metadata at revision 81 ...
* Verifying metadata at revision 98 ...
* Verifying metadata at revision 116 ...
* Verifying metadata at revision 133 ...
* Verified revision 372.

Rename the hard drive original repo folder and 'cp -R' the flash drive copy back to the local disk. Run the same commands again on this new copy on the local disk. Get the same errors.

svnadmin verify /path/to/repo
libsvn: Out of memory - terminating application.

This makes no sense. I've used svn since before the 1.0 days and never seen this before.
Thats odd.

What filesystems are you using?

Local disk - ufs
Flash disk - fat32?

And what filesystem was the repo created on? Sometimes the case insensitive FS can screw things up.

Can you create a new repo, add a few files to it and see similar results?

edit: Hmm, yes, perhaps svn got mangled somewhere. Does reinstalling the package / port help?
I had subversion 'pkg lock'd because I had it built from ports to include sasl. At some point, some dependent library evolved.

Turns out only some commands worked on the flash drive.

To fix, I unlocked it, removed it, and re-installed. All is well now. I will need to restore sasl at some point but I can worry about that later.

This goes under the "don't mix packages and ports" category.