Strange thing with NDIS

Slesarev

Member


Messages: 53

I have Acer Aspire 9410z, with wireless net card.
The pciconf tells me the following:

Code:
none1@pci0:5:0:0:	class=0x028000 card=0x04221468 chip=0x431114e4 rev=0x01 hdr=0x00
    vendor     = 'Broadcom Corporation'
    device     = 'Dell Wireless 1390 WLAN Mini-PCI Card'
    class      = network
    cap 01[40] = powerspec 2  supports D0 D1 D2 D3  current D0
    cap 05[58] = MSI supports 1 message 
    cap 10[d0] = PCI-Express 1 legacy endpoint
Well, there is no unix-driver for this card. I`ve sucessfully (i think) NDISed the original MSWindows driver, sucessfully kldloaded it, but the device did not arrive anywhere. What is wrong here?

(the card was working under infodel OS)
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

Explain what you did.

There is *BSD bwi driver for that card, link is available on this forum.
 
OP
OP
S

Slesarev

Member


Messages: 53

Thanks, now it works.
And - anyway - what was wrong? I did it right as it is written in handbook, and I tried other ways - without that script, by renaming *.o into *.ko and copying it into /boot/modules, /boot/kernel
And result was just similar - the modules were loaded, but no device arrived.
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

You still did not say whay you have done.

Slesarev said:
by renaming *.o into *.ko and copying it into /boot/modules, /boot/kernel
Bad, you should never rename *.o files to *.ko files, *.ko files should be generated automatically with ndisgen.
With this card there should be only one *.ko file named "bcmwl5_sys.ko" and that file or any other should be moved to /boot/modules/ and not to /boot/kernel/

After file have been moved it is loaded with command:
# kldload bcmwl5_sys
Also put in /boot/loader.conf this line:

bcmwl5_sys_load=YES
so that you dont need to load file after every boot.
 
Top