bhyve Strange problem of "mouse pointer becoming unclickable" in bhyve VM

ikevin8me

Active Member

Reaction score: 12
Messages: 198

I'm now experiencing a strange problem of the "mouse pointer becoming unclickable" inside a bhyve VM.

Host OS: FreeBSD 13

bhyve command: (partial) -s 29,fbuf,tcp=192.168.1.72:15900,w=1200,h=1000 \
-s 31,lpc \
-s com1,stdio \
-l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd \
openbsdvm

Guest OS: OpenBSD 6.9 running Xfce

VNC: I tried both Tiger VNC Viewer 64-bit v1.11.0 and Java-based TightVNC v.2.8.3 - both present the same problem.

Descripton: After the VM is booted, I'd VNC-into it and everything is fine. The mouse pointers works (but have double pointers - one for the host and one for the VM - which are not synchronized but this is a different issue.) It'll continue to work as long as I continue using it. However, when I leave the VM idle for several minutes and come back to it, though the mouse pointer can still move inside the VM it can no longer click on anything. That is, clicking on anything inside the VM no longer has no effect. Plus, hovering over any objects that would usually cause some 3D effects no longer work. It's like the VM has lost the pointer, while the illusionary "moving pointer" over the VM actually belongs to the host.

Do anyone know what is going on - what is the cause and how to resolve this?
 

jmos

Well-Known Member

Reaction score: 192
Messages: 260

I have no clue about OpenBSD, but the part you're showing of you bhyve command misses something like -s 8,xhci,tablet, which should at least sync the mouse cursor.

More specific: "22.7.5. Graphical UEFI Framebuffer for bhyve Guests"
 
OP
I

ikevin8me

Active Member

Reaction score: 12
Messages: 198

I've added "-s 8,xhci,tablet" and the cursor sync problem is resolved.

And, by not using Xfce and instead use only the standard X, it seems that "mouse pointer becoming unclickable" is resolved.
 
OP
I

ikevin8me

Active Member

Reaction score: 12
Messages: 198

Surprisingly, I think I found the reason for the "mouse pointer becoming unclickable". I think it is caused by the activation of the Xfce screensaver even though it does not show up (that means, the screen won't change to show some moving icons or somethinng). The reason for the screensaver not showing up if probably due to I did not set the "procfs".
 
Top