Steamuxulation redux

cabriofahrer

Well-Known Member

Reaction score: 20
Messages: 256

Now that it finally works again (the client works like a charm!) and I finally wanted to play CS:GO, I have the following issue with that:
The framerate is so low that it is unplayable, so googeling suggested to disable the multicore setting in the advanced video settings. I tried that and then suddenly the game was pretty fast. But the effect does not persist when the map is changed. After a map change it becomes very slow and unplayable again, although in the settings it is till on "disabled". The behaviour is like this:

When I play the map "Dust II" for the first time, the game (usually) runs normal/fast. After a match and a reload of the map, sometimes it remains fast, sometimes not. Most of the times after the third reload the framerate drops to unplayable again. I don't understand this phenomenon.

TF2: Secure servers still don't work. Any news on that?
 
OP
S

shkhln

Daemon

Reaction score: 970
Messages: 2,224

When I play the map "Dust II" for the first time, the game (usually) runs normal/fast. After a match and a reload of the map, sometimes it remains fast, sometimes not. Most of the times after the third reload the framerate drops to unplayable again. I don't understand this phenomenon.
Odd. As far as I can tell, nobody else has complained about this.

TF2: Secure servers still don't work. Any news on that?
Is it crashing? I don't have desire/capacity to debug non-fatal issues.
 

cabriofahrer

Well-Known Member

Reaction score: 20
Messages: 256

Odd. As far as I can tell, nobody else has complained about this.
It is odd indeed. I don't believe it has something to do with the steam-client. It looks more like an issue of the game itself, I am just posting this in case someone has heard of that, too and knows a solution.

Is it crashing? I don't have desire/capacity to debug non-fatal issues.
Yes, it is. It crashes right before loading the map and you are back to the desktop. You stated yourself a long time ago that this has to do with Steam's secure servers and that it was "under investigation". It is strange that CS:GO does not have that problem, so is that game not using secure servers or are they different to those of TF2?
 

cabriofahrer

Well-Known Member

Reaction score: 20
Messages: 256

I would like to report new findings in relation to CS:GO: The Problem explained in my comment #401 could be solved by reducing some video settings like shaders and shadows. The game now runs fast and smooth even with the multicore setting enabled.
But unfortunately, the game and the whole steam client crash eventually after several minutes. Here is one output I could get from the terminal after a crash:

Code:
311ff000-31200000 rw-p 00b41000 00:00 0
31200000-31a47000 r-xp 00000000 00:00 62613488     /usr/home/steam2/.steam/steam/ubuntu12_32/friendsui.so
31a47000-31b03000 r--p 0108c000 00:00 62613488     /usr/home/steam2/.steam/steam/ubuntu12_32/friendsui.so
31b03000-31b08000 rw-p 01148000 00:00 62613488     /usr/home/steam2/.steam/steam/ubuntu12_32/friendsui.so
31b08000-31b1b000 rw-p 00000000 00:00 0
31c00000-31f3e000 r-xp 00000000 00:00 62613481     /usr/home/steam2/.steam/steam/ubuntu12_32/serverbrowser.so
31f3e000-31f92000 r--p 0067a000 00:00 62613481     /usr/home/steam2/.steam/steam/ubuntu12_32/serverbrowser.so
31f92000-31f93000 rw-p 006ce000 00:00 62613481     /usr/home/steam2/.steam/steam/ubuntu12_32/serverbrowser.so
31f93000-3239d000 rw-p 00000000 00:00 0
3239d000-3239e000 ---p 00000000 00:00 0
3239e000-3249e000 rw-p 0040b000 00:00 0
3249e000-32666000 rw-p 00000000 00:00 0
3269e000-32a9e000 rw-s 00000000 00:00 0
32a9e000-32a9f000 ---p 00000000 00:00 0
32a9f000-32b9f000 rw-p 00001000 00:00 0
32c00000-33151000 rw-s 00000000 00:00 15170
33151000-33551000 rw-s 00000000 00:00 0
33551000-33751000 rw-s 00000000 00:00 0
33800000-33d58000 rw-s 00000000 00:00 15500
33e00000-33e99000 rw-p 00000000 00:00 0
33e99000-33e9a000 rw-p 00000000 00:00 0
33e9a000-33ea2000 rw-p 00001000 00:00 0
33ea2000-33ea6000 rw-p 00009000 00:00 0
33ea6000-33ee6000 rw-p 0000d000 00:00 0
33ee6000-33eee000 rw-p 0004d000 00:00 0
33eee000-33efe000 rw-p 00055000 00:00 0
33efe000-33f01000 ---p 00065000 00:00 0
33f01000-34001000 rw-p 001a9000 00:00 0
34001000-34002000 ---p 00000000 00:00 0
34002000-34102000 rw-p 00001000 00:00 0
34102000-34103000 ---p 00000000 00:00 0
34103000-34203000 rw-p 00000000 00:00 0
34300000-34500000 rw-p 00000000 00:00 0
34500000-34501000 ---p 00000000 00:00 0
34501000-34601000 rw-p 00001000 00:00 0
34a00000-34b00000 rw-p 00000000 00:00 0
34e00000-34e6d000 rw-p 00000000 00:00 0
34e6d000-34f00000 ---p 00000000 00:00 0
34f00000-35100000 rw-p 00dfe000 00:00 0
fbffe000-fffde000 ---p 00000000 00:00 0
fffde000-ffffe000 rw-p 00000000 00:00 0           [stack]
ffffe000-fffff000 r-xs 00000000 00:00 0           [vdso]
Segmentation fault
$ CCrossProcessPipe::BWrite wrote too few bytes: 32 (Broken pipe).  Continuing.
src/common/pipes.cpp (852) : fatal stalled cross-thread pipe (pipe is disconnected).
src/common/pipes.cpp (852) : fatal stalled cross-thread pipe (pipe is disconnected).
src/common/pipes.cpp (852) : Fatal assert; application exiting
src/common/pipes.cpp (852) : Fatal assert; application exiting
ExceptionHandler::GenerateDump waitpid failed:No child processes
AL lib: (EE) ALCplaybackAlsa_mixerProc: mmap commit error: Broken pipe
No minidump written, nothing to upload.
_ExitOnFatalAssert

$
 
OP
S

shkhln

Daemon

Reaction score: 970
Messages: 2,224

Here is one output I could get from the terminal after a crash:
Nothing interesting here: this shows the Steam client existing on a failed assertion check, but not the actual game crash, which this assertion check suggests.
 

Menelkir

Well-Known Member

Reaction score: 349
Messages: 294

It seems there's something going on with webrender, I'm getting a black screen with any section in the main window, anyone aware of this? Maybe I'm missing something?
 

scratchi

Member

Reaction score: 5
Messages: 31

Hello,

Steam just updated itself, and doesn't want to start now. I tried pulling latest from git, recompiling and installing, but it still doesn't launch.

Here is the error that I'm getting:

Code:
$ /opt/steam-utils/bin/steam
ERROR: ld.so: object 'steamfix.so' from LD_PRELOAD cannot be preloaded: ignored.
Updating Steam runtime environment...
/opt/steam-utils/lxbin/zenity: line 5: /usr/local/bin/zenity: No such file or directory
Traceback (most recent call last):
        3: from /opt/steam-utils/bin/../lxbin/upgrade-steam-runtime.rb:12:in `<main>'
        2: from /opt/steam-utils/bin/../lxbin/upgrade-steam-runtime.rb:12:in `chdir'
        1: from /opt/steam-utils/bin/../lxbin/upgrade-steam-runtime.rb:45:in `block in <main>'
/opt/steam-utils/bin/../lxbin/upgrade-steam-runtime.rb:9:in `safe_system': Command failed: "/compat/linux/bin/env PATH=\\"/opt/steam-utils/lxbin:/compat/linux/bin\\" steam-runtime/setup.sh" (RuntimeError)
Traceback (most recent call last):
        1: from /opt/steam-utils/bin/steam:138:in `<main>'
/opt/steam-utils/bin/steam:36:in `safe_system': Command failed: "/opt/steam-utils/bin/../lxbin/upgrade-steam-runtime" (RuntimeError)


Please let me know if any more info is required, hope you can help.

Thank you
 

scratchi

Member

Reaction score: 5
Messages: 31

New game coming, Big Boy Boxing, and the demo is up on steam. Similar style to the NES Punch Out game. The demo works on FreeBSD! I had to use monofix; but it works great :)
 
Top