Solved startx not found

Hello friendly beasties,

startx not found (and neither is my sanity now). Just trying to get "startx" to work with a simple window manager. Run startx and get: "-sh: startx: not found". Have proc at /etc/fstab. Did pkg install xorg.

Have hald_enable="YES" and dbus_enable="YES" in /etc/rc.conf.

Ran "X -configure" as root. Copied to "/etc/X11/xorg.conf". Added "kern.vty=vt" at beginning of "/boot/loader.conf". Using Bourne shell.

Set .profile so that I have a path of:
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/<my account>/bin.
Account is in the wheel group.

Installed windowmaker.

Ran wmaker.inst with my non-root account.

~/.xinitrc only has exec wmaker in it.

What am I missing?

Is there any other information I can provide for you in order to help figure this out?

Thanks in advance,

I'm so sorry. Forgot to mention that I couldn't find it there. I ran the command you listed and received: "/usr/local/bin/startx was not found in the database"
Also, found a thread on this. Did a rehash. Didn't fix it. I did check that I have xorg-server-1.18.4,1 installed.
Did a pkg delete of xorg and a pkg autoremove. Installed it again, did a startx and the TWM came up. Looks like I'm good now.
I seem to recall a similar problem one time when I had installed the DE before installing Xorg. Deleting and doing it the right way around solved my problem.
Order is not important. You can install a DE and then Xorg afterwards. It's not going to matter. The initial problem was probably caused by an installation error with one of the dependencies of x11/xorg. Probably didn't notice the error and it simply failed to install x11/xinit.
Thank you to everyone who took time to look at this and respond. I searched quite a bit before I posted and appreciate your help.