Start Gnome3

jrperezmayo

Member


Messages: 21

Hi, I´m new in FreeBSD. I installed Gnome3 successfuly, but I can´t init it.
I followed the Handbook:
In /etc/fstab:
Code:
proc           /proc       procfs  rw  0   0
In /etc/rc.conf:
Code:
dbus_enable="YES"
hald_enable="YES"
I need something else?
Thanks.
Jorge Ricardo.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,742
Messages: 36,545

Did you install and configure Xorg first? Make sure that works before trying to add a desktop environment.
 
OP
J

jrperezmayo

Member


Messages: 21

Yes, xorg is installed and run perfectly.
I configured to use startx creating ~/.xinitrc. But occur an error and server close.
When execute startx with root, server run with no problem.
 
OP
J

jrperezmayo

Member


Messages: 21

This is the error with startx:
failed to set mtrr: Invalid argument.
D-bus library appears to be incorrectly set up: see the manual page for dbus-uui dgen to correct this issue. (Failed to open "/var/lib/dbus/machine-id": No such file or directory) gnome-session-binary 1042 -- ERROR: Failed to connect to system bus: Could not connect: No such file or directory
aborting...
hostname gnome-session-binary[1042]: ERROR: Failed to connect to system bus: Could not connect: No such file or directory aborting...
xinit: connection to X server lost
waiting for X server to shut down faile to unset mtrr: No such file or directory
(II) Server terminated succesfully (0). Closing log file.
 
OP
J

jrperezmayo

Member


Messages: 21

With Xorg -configure. FreeBSD identify two drivers. Vesa and scfb. The second produce an error. So, I configured vesa in /usr/local/etc/X11/xorg.conf.d/driver-vesa.conf.
With xrandr, error "Can't open display" continues. There is a solution?
 
OP
J

jrperezmayo

Member


Messages: 21

Well, in /etc/rc.conf I have three lines. hald_enable= "YES", gdm_enable= "YES" and gnome_enable= "YES".
That's enougth? i rebooted the system. How can I see the status of dbus?
 

DonK

New Member

Reaction score: 6
Messages: 19

This works for me:

[FONT=courier new]pkg install xorg
pkg install gnome3[/FONT]

/etc/rc.conf

[FONT=courier new]dbus_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
hald_enable="YES"[/FONT]

A reboot causes gnome3 to automagically start, which irritates me a little. But, not quite enough to motivate me to discover why.
 
Top