SSHFS doesn't work under Parallels Desktop 8 for Mac

pietrasm

Member


Messages: 45

Hello,

This is my first post here, therefore I would like to say hi to everyone.

There is an issue. I've installed sysutils/fusefs-sshfs under FreeBSD 9.0 running on Parallels Desktop 8 for Mac. Unfortunately, it doesn't work. I get something like this:
Code:
%mkdir mount-point
%sshfs 192.168.0.128:/Users/pietrasm/Dropbox/uni/FinalProject/src/ mount-point/
Password:
%ls mount-point 
ls: mount-point: Bad file descriptor
%uname -a
FreeBSD MacBook-FreeBSD 9.0-RELEASE-p3 FreeBSD 9.0-RELEASE-p3 #0: Tue Jun 12 02:52:29 UTC 2012
root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
%
I've tried to install it on the different system running on a real machine and it worked.

Is there anything I can do with it?

Thanks.
 

gkontos

Daemon

Reaction score: 488
Messages: 2,160

I have very bad experience with fusefs/-sshfs in FreeBSD. It works up to the point where you try to transfer large files. Then it suddenly looses the mount point.

My suggestion is to try another file sharing protocol.
 
OP
P

pietrasm

Member


Messages: 45

gkontos said:
I have very bad experience with fusefs/-sshfs in FreeBSD. It works up to the point where you try to transfer large files. Then it suddenly looses the mount point.

My suggestion is to try another file sharing protocol.
Is there anything you can suggest to use? I need to share files between Mac and FreeBSD running on VM. I am going to write some code on Mac and compile it and test on FreeBSD. I am not going to transfer large files. The most important for me is an easy setup. I would prefer to do not install any extra software on the Mac.

Is there any way to mount AFP share under FreeBSD? I know that net/netatalk3 can act as a server, but not as a client.

Thanks.
 

gkontos

Daemon

Reaction score: 488
Messages: 2,160

pietrasm said:
Is there anything you can suggest to use? I need to share files between Mac and FreeBSD running on VM. I am going to write some code on Mac and compile it and test on FreeBSD. I am not going to transfer large files. The most important for me is an easy setup. I would prefer to do not install any extra software on the Mac.

Is there any way to mount AFP share under FreeBSD? I know that net/netatalk3 can act as a server, but not as a client.

Thanks.

See the man pages for mount_smbfs(8)(). You can share files from a Mac with SMB.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,331
Messages: 38,847

Simply use scp(1) or sftp(1). Both OS-X and FreeBSD support it by default, no need to install anything. And I'm quite sure you can find a GUI application for it on OS-X.
 
OP
P

pietrasm

Member


Messages: 45

gkontos said:
See the man pages for mount_smbfs(8)(). You can share files from a Mac with SMB.
I will try this, I didn't know that mount_smbfs is a part of base system.
SirDice said:
Simply use scp(1) or sftp(1). Both OS-X and FreeBSD support it by default, no need to install anything. And I'm quite sure you can find a GUI application for it on OS-X.
I can use scp(1) or sftp(1) but I would have to explicitly execute the command after any changes made to the source code. Is there any way to automate it?

I think the net/rsync would be even more suitable but still it requires to be executed after any changes made to the files.

Are there any chances to fix sysutils/fusefs-sshfs? I seems to be the easiest way.

Thanks.
 

kpa

Beastie's Twin

Reaction score: 1,847
Messages: 6,318

I use devel/git for syncing my sources across the systems I have. It can be used with an existing ssh(1) connection, preferably with agent forwarding so you don't have to type passwords every time you push or pull the changes.
 
OP
P

pietrasm

Member


Messages: 45

kpa said:
I use devel/git for syncing my sources across the systems I have. It can be used with an existing ssh(1) connection, preferably with agent forwarding so you don't have to type passwords every time you push or pull the changes.
I use devel/git anyway. Unforunteally, it isn't rather a good idea to commit every minor change before even trying to compile the code.

I need to have either some remote file system or some file system mirroring daemon.

Thanks.
 

kpa

Beastie's Twin

Reaction score: 1,847
Messages: 6,318

I guess it's a matter of taste but GIT actually encourages a kind of development where commits are very small and numerous as described in gitworkflows(7).
 
OP
P

pietrasm

Member


Messages: 45

kpa said:
I guess it's a matter of taste but GIT actually encourages a kind of development where commits are very small and numerous as described in gitworkflows(7).

That's true but I prefer to at least compile the code anyway. Moreover, it still requires to push and pull by hand.

Are there any chanses to fix sysutils/fusefs-sshfs? Otherwise, I go for SMB sharing.

Thanks.
 

gkontos

Daemon

Reaction score: 488
Messages: 2,160

pietrasm said:
Are there any chanses to fix sysutils/fusefs-sshfs? Otherwise, I go for SMB sharing.
Thanks.

I read in the mailing lists that a downgrade to the previous version has solved the Bad file descriptor issue. Apparently you are not the only one who has this problem.
 
OP
P

pietrasm

Member


Messages: 45

gkontos said:
I read in the mailing lists that a downgrade to the previous version has solved the Bad file descriptor issue. Apparently you are not the only one who has this problem.
How can I downgrade a port?

Many thanks.
 
OP
P

pietrasm

Member


Messages: 45

pietrasm said:
How can I downgrade a port?

Many thanks.

Ok, I have managed to downgrade the sysutils/fusefs-sshfs to version 2.3.

Now I get something like this:
Code:
%mkdir mnt-point
%sshfs 192.168.0.128:/Users/pietrasm/Dropbox/uni/FinalProject/src/ mnt-point/
^C
%sshfs 192.168.0.128:/Users/pietrasm/Dropbox/uni/FinalProject/src/ mnt-point/
fuse: bad mount point `mnt-point/': Bad file descriptor
%sshfs -V
SSHFS version 2.3
FUSE library version: 2.9.2
mount_fusefs [fuse4bsd] version: 0.3.9-pre1
using FUSE kernel interface version 7.19
%
Sshfs doesn't prompts for password, nothing happens for a very long time. When I interrupt it, the mnt-point directory becomes corrupted.

Any other suggestions?

Thanks.
 
OP
P

pietrasm

Member


Messages: 45

I have emailed sysutils/fusefs-sshfs's maintainer and he told me to read pkg-message:
Code:
Basic Instructions:
There are three ways to do this:

Daemon initiated

1)
% sshfs -o idmap=user username@example.org: /path/to/mount/point

or

2)
% mount_fusefs auto /path/to/mount/point sshfs -o idmap=user \
       username@example.org:

or

3)
% env FUSE_DEV_NAME=/dev/fuse0 sshfs -o idmap=user \
       username@example.org:
% mount_fusefs /dev/fuse0 /path/to/mount/point

For further options see ``sshfs -h''.
It works after adding -o idmap=user option. The problem solved.

Thank you all for help.
 
Top