Solved ssh receive reset package randomly, Fssh_packet_write_poll: Connection from user user a.a.a.a port 38142: Permission denied

nerozero

Active Member

Reaction score: 18
Messages: 162

Hello,

I have a firewall issue, dropping randomly ssh connections.
in the /var/log/auth.log: Fssh_packet_write_poll: Connection from user user x.x.x.x port 37832: Permission denied

here is my the firewall rules:
Code:
00100   28   1400 allow ip from any to any via lo0
00200    0      0 deny ip from any to 127.0.0.0/8
00300    0      0 deny ip from 127.0.0.0/8 to any
00400    0      0 deny ip from any to ::1
00500    0      0 deny ip from ::1 to any
00600    0      0 allow ipv6-icmp from :: to ff02::/16
00700    0      0 allow ipv6-icmp from fe80::/10 to fe80::/10
00800    0      0 allow ipv6-icmp from fe80::/10 to ff02::/16
00900    0      0 allow ipv6-icmp from any to any icmp6types 1
01000    0      0 allow ipv6-icmp from any to any icmp6types 2,135,136
50000 1193 383804 nat 1 ip from any to any via igb0
65530 5752 469032 allow ip from any to any
65535    0      0 deny ip from any to any

And nat config: ipfw nat 1 config if igb0 log same_ports reset

I can login to ssh, work normally for an hour, or 5 min. An suddenly, completely random receiving "Broken pipe" event.
Don't have this issue if i'm adding: ipfw add 1 allow all from any to any

please pay attention, nothing is blocked by the firewall.
I have a strong feeling this is a nat rule issue....

Please help
 
OP
nerozero

nerozero

Active Member

Reaction score: 18
Messages: 162

covacat, thanks ! it does helps !!!!!

Notes for others (future me included :) ) who will found this post:
To disable TSO at boot time add "-tso" to interface config:
Code:
~~~ cat /etc/rc.conf ~~~
---- 8< ----
ifconfig_igb0="inet 10.20.30.40 netmask 255.255.255.248 -tso"
---- 8< ----
~~~ end cat ~~~
 
Top