Solved Soundcard drivers RME Adi 2 Pro

Lars Skogstad

Member

Reaction score: 12
Messages: 53

Hello

Ive installed FreeBSD 11.1 with KDE5 Plasma, everything seems to be stable and working fine.
It discovered all my hardware even my printer but not my external USB soundcard.

Im using a RME Adi 2 Pro - usb soundcard and ive been trying to search around for answers with no luck.

I found a guy that has made: HQplayer for for Windows,Mac and Linux but not for FreeBSD.

So.. I sent him a mail and he answered:

"
I would assume ADI-2 Pro to already work fine on FreeBSD since it is UAC
compliant device. The custom functionality I've made driver support for
Linux is not there, but based on what you describe it is not needed
either in your case."

What does that mean regarding UAC compliant device?
And does anyone else have some suggestions?
I dont need support for all the onboard stuff, I just want headphones out and main output to work, dont need it to run any more than 44100kHz/48000kHz 24 bit.


I know FreeBSD has support for the RME HDSPe series which I tried to use but with no luck.
Are there other viable options?

Out of ideas atm, bothering me a bit to use my Realtek onboard soundcard when I have this newer and much better soundcard available.


- Lars Skogstad
 
OP
OP
Lars Skogstad

Lars Skogstad

Member

Reaction score: 12
Messages: 53

Hmm, but im not sure if its supported at all, the RME card.

cat /dev/sndstat
Installed devices:
pcm0: <NVIDIA (0x0071) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0071) (HDMI/DP 8ch)> (play)
pcm2: <NVIDIA (0x0071) (HDMI/DP 8ch)> (play)
pcm3: <NVIDIA (0x0071) (HDMI/DP 8ch)> (play)
pcm4: <Realtek ALC889 (Rear Analog 7.1/2.0)> (play/rec) default
pcm5: <Realtek ALC889 (Front Analog)> (play/rec)
pcm6: <Realtek ALC889 (Rear Digital)> (play)
pcm7: <Realtek ALC889 (Onboard Digital)> (play)
pcm8: <Intel Cougar Point (HDMI/DP 8ch)> (play)
pcm9: <USB audio> (play/rec)
No devices installed from userspace.

Would it be the PCM9 that is found here?
Not too experienced with fbsd..
 
OP
OP
Lars Skogstad

Lars Skogstad

Member

Reaction score: 12
Messages: 53

snd_hdspe(4)
RME HDSPe AIO , RME HDSPe RayDAT

The snd_hda(4) driver supports more than two hundred different controllers and CODECs. There is no sense to list all of them here, as in most cases specific CODEC configuration and wiring are more important then type of the CODEC itself.
--

So you are thinking of trying the snd_hdspe(4) and see if that is working, not following
 
OP
OP
Lars Skogstad

Lars Skogstad

Member

Reaction score: 12
Messages: 53

Thanks. It actually worked. Was a user mistake by me, had to restart the USB audio device after loading in sound and then switching mixer to the output of PCM10 ( showed up as new USB output ) :) Thank you very much
 
Top