Sound does not work on Dell Inspiron 15 7579

whyisok

New Member


Messages: 11

My sound does not work.Here is the output of dmesg | grep pcm
Code:
pcm0: <Realtek ALC225 (Analog)> at nid 33 and 18 on hdaa0
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
pcm0: <Realtek ALC225 (Analog)> at nid 33 and 18 on hdaa0
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
pcm0: <Realtek ALC225 (Analog)> at nid 33 and 18 on hdaa0
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
pcm0: <Realtek ALC225 (Analog)> at nid 33 and 18 on hdaa0
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
pcm0: <Realtek ALC225 (Analog)> at nid 33 and 18 on hdaa0
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
Also here is the output of cat /dev/sndstat
Code:
Installed devices:
pcm0: <Realtek ALC225 (Analog)> (play/rec) default
pcm1: <Intel Kaby Lake (HDMI/DP 8ch)> (play)
No devices installed from userspace.
Edit Here is the output of mixer
Code:
Mixer vol      is currently set to  85:85
Mixer pcm      is currently set to 100:100
Mixer rec      is currently set to  37:37
Mixer ogain    is currently set to 100:100
Mixer monitor  is currently set to  67:67
Recording source: monitor
 
Last edited by a moderator:

Alexander88207

Aspiring Daemon

Reaction score: 355
Messages: 580

Hello,

default means that he is using pcm0 :D

Does it work if you using the headphones output?

The speakers could be also on pcm1.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,591
Messages: 37,913

Where are your speakers connected to?
 
OP
W

whyisok

New Member


Messages: 11

pindump
hdaa0: nid 0x as seq device conn jack loc color misc
hdaa0: 18 b7a60150 5 0 Mic Fixed Digital Lid-In Unknown 1
hdaa0: Caps: IN
hdaa0: 19 40000000 0 0 Line-out None Unknown 0x00 Unknown 0 DISA
hdaa0: Caps: IN
hdaa0: 20 901701a0 10 0 Speaker Fixed Analog Internal Unknown 1 DISA
hdaa0: Caps: OUT EAPD Sense: 0x00000000 (disconnected)
hdaa0: 22 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: OUT HP Sense: 0x80000000 (connected)
hdaa0: 23 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: OUT HP Sense: 0x00000000 (disconnected)
hdaa0: 24 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: IN Sense: 0x00000000 (disconnected)
hdaa0: 25 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: IN VREF Sense: 0x00000000 (disconnected)
hdaa0: 26 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: IN VREF Sense: 0x00000000 (disconnected)
hdaa0: 27 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: IN OUT EAPD VREF Sense: 0x80000000 (connected)
hdaa0: 30 411111f0 15 0 Speaker None 1/8 Rear Black 1 DISA
hdaa0: Caps: OUT
hdaa0: 33 04211020 2 0 Headphones Jack 1/8 Right Black 0
hdaa0: Caps: OUT HP EAPD Sense: 0x00000000 (disconnected)
hdaa0: NumGPIO=3 NumGPO=0 NumGPI=0 GPIWake=0 GPIUnsol=1
hdaa0: GPIO0: disabled
hdaa0: GPIO1: disabled
hdaa0: GPIO2: disabled
hdaa1: Dumping AFG pins:
hdaa1: nid 0x as seq device conn jack loc color misc
hdaa1: 3 18560010 1 0 Digital-out Jack Digital 0x18 Unknown 0
hdaa1: Caps: OUT Sense: 0x00000000 (disconnected)
hdaa1: NumGPIO=0 NumGPO=0 NumGPI=0 GPIWake=0 GPIUnsol=0
 
OP
W

whyisok

New Member


Messages: 11

I have gotten sound working with earbuds.but still no sound in my internal speakers
 
Top