(Solved) Wireless reboot hang problem

I have a Toshiba Satellite A205 that I have installed FreeBSD 11-CURRENT on. I initially installed FreeBSD while connected by ethernet cable thinking packages would download faster and I would configure a wireless connection manually as shown in the Handbook. I installed the system and the Xfce desktop and then configured the wifi network manually and then tried to reboot but it hung. Shutting down is no problem, but rebooting either by command line or through the desktop and it hangs.
I then did a reinstall thinking I made a configuration error and set up wifi during install without an ethernet cable. Same thing. It hung at the first reboot.
According to the FreeBSD installer, the network card is an Atheros 5424/2424.
I searched for a fix but the only workaround I could find was to enter

# ifconfig wlan0 down
# shutdown -r now

and then it would reboot properly.
Any ideas on how to fix this?
Thank you.
There are some knobs you could try. The problem could be ACPI related:

I am guessing this is an older device with Mini PCI wireless card? My AR5524 was Mini PCI.

This is my pciconf -lv regarding my Atheros:

ath0@pci0:5:0:0: class=0x020000 card=0x7128144f chip=0x001c168c rev=0x01 hdr=0x00
vendor = 'Qualcomm Atheros'
device = 'AR242x / AR542x Wireless Network Adapter (PCI-Express)'
class = network
subclass = ethernet

It looks like you're also correct about my device being a Mini PCI Wireless Card?