• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved [Solved] /var/empty upgrade from 9.2-RELEASE to 10.0-RELEASE

fbrulotte

New Member


Messages: 2

#1
Last week I just upgraded successfully from 8.2-RELEASE to 9.2-RELEASE.

Now is the time to upgrade to 10.0-RELEASE but I always get the same error and after searching for a solution, it does not seems a common problem:

# freebsd-update fetch install
Code:
Looking up update.FreeBSD.org mirrors... 5 mirrors found.
Fetching metadata signature for 9.2-RELEASE from update6.freebsd.org... done.
Fetching metadata index... done.
Inspecting system... done.
Preparing to download files... done.

No updates needed to update system to 9.2-RELEASE-p3.
No updates are available to install.
# freebsd-update upgrade -r 10.0-RELEASE



# freebsd-update install
Code:
Installing updates...chflags: ///var/empty: Read-only file system
 

dpejesh

Member

Thanks: 10
Messages: 74

#2
Re: /var/empty error upgrading from 9.2-RELEASE to 10.0-RELE

If I remember right this is from /var/empty having schg flag on it. You can verify with ls -lod /var/empty. If it does you'll see schg after the group column. To remove it run chflags noschg /var/empty.

EDIT: Now that I think about it, is this on a ZFS file system? It's been awhile since I ran into this problem and it might have been from the ZFS readonly attribute being set.
 

fbrulotte

New Member


Messages: 2

#3
Re: /var/empty error upgrading from 9.2-RELEASE to 10.0-RELE

Thanks for putting me on track.

I had already tried the following:

# chflags noschg /var/empty
Code:
chflags: /var/empty: Read-only file system
But talking about the readonly ZFS attribute, made me found the solution:

# zfs get readonly zroot/var/empty
Code:
NAME             PROPERTY  VALUE   SOURCE
zroot/var/empty  readonly  on      local
# zfs set readonly=off zroot/var/empty

Then I could proceed with normal upgrade and put back /var/empty readonly later:
# zfs set readonly=on zroot/var/empty
 
Top