Solved [Solved] Unable to start KDE4

Grendel

New Member


Messages: 14

#1
HI,

After a recent disk crash, I rebuilt KDE4 from source. I am unable to get it to run. I usually use startx which eventually runs startkde. However, it quits when it tries to start qdbus. It appears that qdbus is crashing. There is a core in my home directory. Anyone, experience this? Is there a work around? Can I get qdbus running before using startx?
 
OP
OP
G

Grendel

New Member


Messages: 14

#2
Re: Unable to start KDE4

A little more info. I'm running version 9.2-RELEASE-p5 of FreeBSD. The ports tree is up to date. Xorg and KDE are entirely installed. The backtrace on the qdbus core file is as follows:

Code:
#0  0x2862b9cb in thr_kill () from /lib/libc.so.7
#1  0x285bf9a6 in pthread_sigmask () from /lib/libthr.so.3
#2  0x285c01db in raise () from /lib/libthr.so.3
#3  0x286d607a in abort () from /lib/libc.so.7
#4  0x2a822435 in _dbus_abort () from /usr/local/lib/libdbus-1.so.3
#5  0x2a817f16 in _dbus_warn_check_failed () from /usr/local/lib/libdbus-1.so.3
#6  0x2a817fda in _dbus_get_local_machine_uuid_encoded ()
   from /usr/local/lib/libdbus-1.so.3
#7  0x2a81f367 in _dbus_get_autolaunch_address ()
   from /usr/local/lib/libdbus-1.so.3
#8  0x2a814886 in _dbus_transport_open () from /usr/local/lib/libdbus-1.so.3
#9  0x2a81471d in _dbus_transport_open () from /usr/local/lib/libdbus-1.so.3
#10 0x2a7feb09 in _dbus_connection_close_possibly_shared ()
   from /usr/local/lib/libdbus-1.so.3
#11 0x2a7f9419 in dbus_bus_register () from /usr/local/lib/libdbus-1.so.3
#12 0x28096457 in QDBusConnection::connectToBus ()
   from /usr/local/lib/qt4/libQtDBus.so.4
#13 0x28098915 in QDBusConnection::systemBus ()
   from /usr/local/lib/qt4/libQtDBus.so.4
#14 0x28098adf in QDBusConnection::sessionBus ()
   from /usr/local/lib/qt4/libQtDBus.so.4
#15 0x08052041 in ?? ()
#16 0x0804c29a in ?? ()
#17 0x00000001 in ?? ()
#18 0xbfbfdbbc in ?? ()
#19 0xbfbfdbc4 in ?? ()
#20 0xbfbfdba0 in ?? ()
#21 0xbfbfdbb8 in ?? ()
#22 0x00000000 in ?? ()
 
OP
OP
G

Grendel

New Member


Messages: 14

#3
Re: Unable to start KDE4

Ok, I have resolved this issue. It appears the qdbus was compiled so that it looks for the file machine-id in /etc instead of in /var/db/dbus. Once I copied machine-id into /etc, all was well.
 
Top