Solved [Solved]Swap access causes reboot (powerpc 9.2)

redchard

New Member


Messages: 15

(Edit: Sorry, I forgot to name the arch in the topic heading.)

I have installed FreeBSD-powerpc on an iMac DV (400Mhz, slot-loading) with 1Gb of RAM and a 40Gb Maxtor HD; actually I have installed it twice, once with 10 and now 9.2.

Both times my attempts to configure xorg failed after setting the
Code:
Option "VGAAccess" "True"
and resulted in a continuous loop of core crashes.

I found then that the only way to stop the cycle of rebooting and crashing (during boot) was through the boot-only cd, or booting into single-user mode. When I tried to run
Code:
vi
in single-user mode, the crash happened again.

So, I now think that the crashes occur anytime the system tries to access the swap partition. (So, when savecore tries to access /var, or vi tries to create a buffer on /tmp.)

For both installations, I used the entire disk and accepted the "auto" partitioning scheme generated by sysinstall. But that only creates the Apple partition, plus a main ufs and a swap partition (though /var and /tmp are both on the main ufs).

I had thought that, since 9.2, sysinstall knows how to partition for ppc; is that not true? Do the mount points still need to be set up on separate partitions?

Can I do this using gpart on my running system, or do I have to reinstall for a third time?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,515
Messages: 30,196

Re: Swap access causes reboot (powerpc 9.2)

If the crashing also happens when you've booted to single user mode I doubt it has anything to do with swap. In single user mode only the root file system is mounted, read-only even. Swap hasn't been turned on yet. Because it's a Tier 2 platform you may have some more luck with trying 9-STABLE. But getting there will be difficult if the machine keeps crashing.

It shouldn't matter if you have one large root partition or the older scheme with separate /usr/, /var/ and /tmp/ partitions.
 
OP
OP
R

redchard

New Member


Messages: 15

Re: Swap access causes reboot (powerpc 9.2)

Actually, when I boot into single-user I have to run
Code:
fsck -y
and then
Code:
mount -a -t ufs
so that I can use anything.

Then:
Code:
swapon -a
I was trying to edit
Code:
/etc/rc.conf
with vi when it caused reboots similar to those that happen when booting multi-user.

So, that's why I say it seems to happen whenever the system tries to access swap.
 
OP
OP
R

redchard

New Member


Messages: 15

Re: [Semi-Solved]Swap access causes reboot (powerpc 9.2)

I booted into single-user and used tunfs -j to turn journaling off on my main partition. Then ran fsck on the same slice without the -y flag. Without journaling, fsckruns much more slowly, but it was able to actually clean the filesystem. The system now boots cleanly despite pausing much longer at the filesystem check, and it does not crash when accessing /var or /tmp. So, vi(1) works again.

I say, "semi-solved", because the pkgngutilities no longer seem to know where the package db is. If I cd I can see the listings for installed ports in /var/db/pkg, but pkg info <installed pkg> says <installed pkg> is not found.

Do I need to deinstall and reinstall PKGNG?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,515
Messages: 30,196

Re: [Semi-Solved]Swap access causes reboot (powerpc 9.2)

Ah, so it looks like PowerPC has an issue with journaling. It might be worthwhile reporting this on the freebsd-ppc@ mailing list.

redchard said:
I say, "semi-solved", because the pkgng utilities no longer seem to know where the package db is. If I cd I can see the listings for installed ports in /var/db/pkg, but pkg info <installed pkg> says <installed pkg> is not found.
If you see subdirectories with names like www_apache22 you still have the old packages installed. Did you run pkg2ng after installing ports-mgmt/pkg?
 
OP
OP
R

redchard

New Member


Messages: 15

@SirDice I had not run pkg2ngafter reinstalling pkg; thank you for reminding me. I did so and all is well again.

Now . . . back to wrestling with Xorg . . .
 
Top