• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved [Solved] Squid 3.3 on FreeBSD10 Access line contains no ACLs

dsbeerf1

New Member


Messages: 2

#1
Hi all. Sorry in advance for my inexperience.

I have Squid 3.3 (squid33 in ports) installed on my FreeBSD 10 system along with IPFW.

Here is the output of uname -a:
Code:
FreeBSD DC-S101.drasticraft.com 10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789: Thu Jan 16 22:34:59 UTC 2014     root@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
I want Squid to allow all incoming connections from anywhere. Yes, I know this is a bad idea taken out of context but I have a different firewall solution on the 'front lines' so to speak.

Using this squid.conf
Code:
http_access allow
http_port 3128 transparent
visible_hostname DC-S101
I get this error when running squid:
Code:
Access line contains no ACL's, skipping
I know that I need a line such as
Code:
acl my_network src network_range
But I am not sure as to how I can allow all IPs.
 

junovitch@

Daemon
Developer

Thanks: 607
Messages: 1,773

#2
Re: Squid 3.3 on FreeBSD10- Access line contains no ACL's

You need to allow something.
Code:
http_access allow my_network
There are tons of examples in the squid.conf.documented and somewhat less in the squid.conf.default. Search for "localnet" for an example. Tweak that or add another entry similar with it with a matching rule like above and you should be good to go.