Solved [Solved] Server reboots during boot - problem mounting

kotori

New Member


Messages: 2

Hello,

I apologize in advance if I neglected some obvious way to solve my problem as I'm completely new to FreeBSD (I have a little knowledge of Linux). I want to make a little FreeBSD server out of an old computer: IBM NetVista, Celeron processor, 128 MB of RAM and 20 GB Maxtor hard drive.

I have performed the install several times using different options (first "vanilla" with default options; GPT, BSD labels, eventually MBR with a BSD slice for the disk; leaving moused, ntpd and powerd out of the starting services; deactivating many options in the BIOS) but it didn't change anything.

The install works without problem but when I boot, the computer reboots itself after showing the line:
Code:
Trying to mount root from ufs:/dev/ada0s1a[rm]
(or
Code:
start_init: trying /sbin/init
if I change some boot options)

When I say "reboot", I don't mean going through the "init 6" process, just the screen going black and the boot loader showing a few seconds after. Sometimes in single user and safe mode it runs a minute or two before rebooting. The moment it reboots seems to be completely random, although trying to use autocompletion seems to cause it every time (from trying to write on a read-only mounted / or /tmp partition I suppose).

I didn't find much in dmesg or /var/log/messages (or the other logs) except for:

Code:
WARNING : / was not properly mounted
sometimes, and
Code:
ada0: Previously known as ad0
(not sure if the last one is relevant though)

I also found what was after the above lines in a "successful" boot:
Code:
setting hostuuid [some long string]
If I boot with the install CD inserted, I can access the system as it first mounts its root partition from the CD. Sometimes it presents me with the menu to choose from install, shell or liveCD, sometimes it seems it boots my system directly first mounting the CD root partition (like if I chose "shell" in the menu). But it stills reboots randomly after 10-20 minutes. Sometimes the only mounted partition is the / from the CD, sometimes I can see my actual partitions mounted with options:
Code:
ufs, local, journaled soft-updates
I tried to write files to them then and it worked.

I have been able to mount my real root partition in /mnt, run a fsck on it and it seemed fine (although I never had to run fsck so I may have missed something). I then did the same for /var, /usr, /tmp, with the same results (it did correct some stuff after unwanted reboots though). I tried to disable the UFS softupdates and journaling system on the root partition to see if it could be mounted properly during boot, it didn't work. /etc/fstab seems just like the ones I can find on the net or FAQs (UFS filesystem, rw option). Here is the actual line:

Code:
/dev/ada0s1a         /              ufs               rw               1               1
When only the CD root partition is mounted, fdisk gives:

Code:
# fdisk /dev/ada0s1a
[...]
Figures below won't work with BIOS for partitions not in cylinder 1
[...]
Warning: BIOS sector numbering starts with sector 1
The data for partition 1 is:
<UNUSED>
[same thing for partition 2 and 3]
The data for partition 4 is :
sysid 165 (0xa5), (FreeBSD/NetBSD/386BSD)
       start 0, size 50000 (24 Meg), flag 80 (active)
                 beg: cyl 0/head 0/ sector 1;
                 end: cyl 1023/head 254/sector 63
Before pinpointing the problem, I read somewhere on the internet that someone had a similar problem of random reboots during boot because of USB2 being activated in the BIOS so I tried to deactivate everything I could there (USB support, audio support, PS2 mouse support, etc...) but it didn't change anything. I didn't find any topics on the forums or in the FAQs of people having the same problem.

Since I tried many options for different installs and various changes in my BIOS, I'm afraid I mixed some information.Is there any log/information I could provide to be more precise?

Currently I have a MBR table pointing to a BSD slice with /, /usr, /var and /tmp partitions (plus a swap).

Thank you,
kotori
 

wblock@

Beastie Himself
Developer

Reaction score: 3,683
Messages: 13,851

Re: server reboots during boot - problem mounting root parti

What version of FreeBSD are you using?

Have you tested the system's memory and hard drive to rule out a hardware failure?
 
OP
K

kotori

New Member


Messages: 2

Re: server reboots during boot - problem mounting root parti

I was testing it with System Rescue CD and even it rebooted so it looked like hardware failure, but I took the time to install it on a similar computer as I saw when mounting the root partition in Linux that
Code:
UFS was compiled with read-only option, can not mount with write...
or something like that.

I installed FreeBSD 9.2 on the other one too and it works, so it was the hardware.

Thank you.
 
Top