• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved [Solved] powerd on a HP 6735s notebook

thuglife

Active Member

Thanks: 42
Messages: 160

#1
Hello guys, i have some issues with an AMD Turion and powerd on a HP 6735s notebook.

When i start powerd i get the following error repeatedly and the machine hangs.

Code:
kernel: hwpstate0: set freq failed, err 6
Code:
> dmesg | grep -i cpu
CPU: AMD Turion(tm)X2 Dual Core Mobile RM-70 (2000.08-MHz K8-class CPU)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID: 0
 cpu1 (AP): APIC ID: 1
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
hwpstate0: <Cool`n'Quiet 2.0> on cpu0
cpu1: <ACPI CPU> on acpi0
SMP: AP CPU #1 Launched!
Code:
> sysctl dev.cpu
dev.cpu.0.%desc: ACPI CPU
dev.cpu.0.%driver: cpu
dev.cpu.0.%location: handle=\_PR_.CPU0
dev.cpu.0.%pnpinfo: _HID=none _UID=0
dev.cpu.0.%parent: acpi0
dev.cpu.0.freq: 1000
dev.cpu.0.freq_levels: 2000/15620 1750/13667 1500/11715 1250/9762 1000/5605 875/4904 750/4203 625/3503 500/2320 437/2030 375/1740 312/1450 250/1160 187/870 125/580 62/290
dev.cpu.0.cx_supported: C1/0
dev.cpu.0.cx_lowest: C1
dev.cpu.0.cx_usage: 100.00% last 500us
dev.cpu.1.%desc: ACPI CPU
dev.cpu.1.%driver: cpu
dev.cpu.1.%location: handle=\_PR_.CPU1
dev.cpu.1.%pnpinfo: _HID=none _UID=0
dev.cpu.1.%parent: acpi0
dev.cpu.1.cx_supported: C1/0
dev.cpu.1.cx_lowest: C1
dev.cpu.1.cx_usage: 100.00% last 500us
Code:
# uname -a
FreeBSD hedland 8.0-STABLE FreeBSD 8.0-STABLE #0: Mon Feb 15 19:15:05 EET 2010 root@hedland:/usr/obj/usr/src/sys/GENERIC amd64
Is this some kind of hw bug because i could not find much related info with google.

Any help would be much appreciated.
 

gen

New Member


Messages: 3

#2
Hi thuglife.

your sysctl dev.cpu.0.freq_levels is
Code:
dev.cpu.0.freq_levels: 2000/15620 1750/13667 1500/11715 1250/9762 1000/5605 875/4904 750/4203 625/3503 500/2320 437/2030 375/1740 312/1450 250/1160 187/870 125/580 62/290
so, 62MHz is very slow. So,
please write
Code:
hint.acpi_throttle.0.disabled="1"
and also
Code:
debug.hwpstate_verbose="1"
in /boot/loader.conf
and reboot. and see debug messages.

Cheers,
gen
 

gen

New Member


Messages: 3

#3
also,

Hi thuglife.

my suggestions of solution are,
1) BIOS update?
2) one by one setting
Code:
  sysctl dev.cpu.0.freq=2000
  sysctl dev.cpu.0.freq=1750
  sysctl dev.cpu.0.freq=1500
  sysctl dev.cpu.0.freq=1250
  sysctl dev.cpu.0.freq=1000
  sysctl dev.cpu.0.freq=875
  sysctl dev.cpu.0.freq=750
  sysctl dev.cpu.0.freq=625
  sysctl dev.cpu.0.freq=500
  sysctl dev.cpu.0.freq=437
  sysctl dev.cpu.0.freq=375
  sysctl dev.cpu.0.freq=312
  sysctl dev.cpu.0.freq=250
  sysctl dev.cpu.0.freq=187
  sysctl dev.cpu.0.freq=125
  sysctl dev.cpu.0.freq=62
And if you cannot set a specifical freq
set sysctl debug.cpufreq.lowest=the threshold freq.
3) if you do 2) and can set lower freq than cannot,
please write hint.acpi_throttle.0.disabled="1" in /boot/loader.conf
and try again.
4) please write debug.hwpstate_verbose="1" in /boot/loader.conf and
see debug messages.
5) please show me powerd -v output with kernel messages.

Sorry for inconvenience.

Regards.
 

gen

New Member


Messages: 3

#4
Maybe Solution

Hi.
Maybe this is the solution.(workaround?)
just write
hint.acpi_throttle.0.disabled="1"
in /boot/loader.conf
and reboot
 

thuglife

Active Member

Thanks: 42
Messages: 160

#5
Thank you very much for your reply, unfortunately
this was a friend's laptop and he installed another OS.

Power management was a big issue for him,
nevertheless i will try to test this and report back.
 

taromaru

New Member

Thanks: 2
Messages: 19

#7
I know this is pretty much an old post, anyway, I happen to own a Compaq 6735s and stumbled upon the same issues.

I experienced this problem with both Ubuntu 10.04/32bit, OpenBSD 4.7/i386 and FreeBSD 8.0/amd64, release branches.

I just restored factory defaults and updated my BIOS, unluckily, the problem seems to stop when using Vista. I will next try it again with FreeBSD and report and post relevant output.

Thanks for your support :)
 

thuglife

Active Member

Thanks: 42
Messages: 160

#8
Thank you guys, we tried FreeBSD again today and hint.acpi_throttle.0.disabled="1" resolves this issue!

One more happy customer. Keep rockin!
 
Top