Solved [Solved] Issue when executing shc command

tempuser

New Member


Messages: 5

Hi all,

I am trying to create an executable using shc. I have a script which is creating ten executables. The executables being created have the below issue. The message "Please contact your provider" is displayed even though I am not using the -e option. This message is coming for some executables being created, i.e. out of ten executables which are created, say 4-5 executables have this issue. And when the next time I am creating the executables again, again the same issue exists but it may be for some other executable.

Command to create executable: shc –r –f < executable_name>
Example:
  1. Executable1
  2. Executable2
  3. Executable3
  4. Executable4
  5. Executable5
  6. Executable6
  7. Executable7
  8. Executable8
  9. Executable9
  10. Executable10
When I run the executable I get the message
Code:
 Executable1: has expired!
Please contact your provider
Next time I create the executable, the same issue may or not be present for Executable1 but is present for some other executable.

Even if I specify the -e clause I still face the same issue: shc –r –e 10/01/2020 –f <executable_name>

Please suggest how to solve this issue.

Thanks.
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,637
Messages: 13,850

Re: Issue when executing shc command

What are the executables for?
 
OP
OP
T

tempuser

New Member


Messages: 5

Re: Issue when executing shc command

Executables are to be delivered to the customer. They are shell scripts only.
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,637
Messages: 13,850

Re: Issue when executing shc command

Try running it with a full path in case there is an alias or wrapper in the path before it: /usr/local/bin/shc ....
 
OP
OP
T

tempuser

New Member


Messages: 5

Re: Issue when executing shc command

There is no issue in creating the executables. The problem is when the executable is created, some of them have the issue as defined above. And the behaviour is also random.
 
OP
OP
T

tempuser

New Member


Messages: 5

Re: Issue when executing shc command

I was able to solve the issue. The problem was present in the way shc was installed. It was installed by someone else and I re-installed (i.e. make file) and it worked fine. Thank you all for your inputs and suggestions.
 
Top