[Solved] Freebsd doesn't boot after install


New Member

Reaction score: 2
Messages: 15

I had similar problem like in this thread
and i tried everything adviced.

On a quite old pc (lenovo thinkcenter m72e), if i make the "standard" installation, the pc doesn't boot.
I tried tuning bios setting (uefi on/off, priorities), using mbr, gpt, bsd, with a freebsd-boot partition, an efi partition, but nothing worked.

This is the way i used to solve the problem.
I burned on a usb key the mini-memstick image (because the standard memstick on my pc doesn't boot in legacy mode, only in uefi mode).
Then, i chose booting from legacy (when you choose from which device booting, on the usb freebsd stick there are two options: legacy and uefi).
Then on the destination hd use MBR for partitioning, create a single freebsd partition, and then a ufs slice in it, then continue installation.
Maybe you have to set up the bios for enabling legacy-mode-boot.

If you really need gpt partition could be a problem, because i tried the same procedure choosing gpt but it doesn't boot.

Maybe the problem is a buggy bios (but ubuntu works perfectly), but i can't update it because the updater is a windows application, and i don't want to install and pay windows just for update the bios!

Hope can be useful for someone stuck in a similar problem on quite old uefi-pc.