Solved [SOLVED] buildworld stops on -STABLE i386

ORTO-DOX

Member

Reaction score: 1
Messages: 78

Good day!

I have a problem with upgrading my system from
Code:
uname -a
FreeBSD OLD-BSD 10.0-CURRENT FreeBSD 10.0-CURRENT #0: Sun Oct 14 20:36:00 MSK 2012     user@OLD-BSD:/usr/obj/usr/src/sys/OLDBSD  i386
to the latest -STABLE.

I think the problem is related to the message in /usr/src/UPDATING:

NOTE: FreeBSD has switched from gcc to clang. If you have trouble bootstrapping
from older versions of FreeBSD, try WITHOUT_CLANG to bootstrap to the tip of
stable/10, and then rebuild without this option. The bootstrap process from
older version of current is a bit fragile.
So I put this in /etc/src.conf:

Code:
WITHOUT_ACCT=YES
WITHOUT_ACPI=YES
WITHOUT_AMD=YES
WITHOUT_APM=YES
WITHOUT_ASSERT_DEBUG=YES
WITHOUT_ATF=YES
WITHOUT_ATM=YES
WITHOUT_AUDIT=YES
WITHOUT_AUTHPF=YES
WITHOUT_BLUETOOTH=YES
WITHOUT_BSNMP=YES
WITHOUT_CAPSICUM=YES
WITHOUT_CLANG=YES
WITHOUT_CLANG_IS_CC=YES
WITHOUT_CTM=YES
WITHOUT_CVS=YES
WITHOUT_DICT=YES
WITHOUT_EXAMPLES=YES
WITHOUT_FLOPPY=YES
WITHOUT_FREEBSD_UPDATE=YES
WITHOUT_GAMES=YES
WITHOUT_GDB=YES
WITHOUT_HTML=YES
WITHOUT_INET6=YES
WITHOUT_INFO=YES
WITHOUT_IPFILTER=YES
WITHOUT_IPX=YES
WITHOUT_JAIL=YES
WITHOUT_KDUMP=YES
WITHOUT_KERBEROS=YES
WITHOUT_KERNEL_SYMBOLS=YES
WITHOUT_KVM=YES
WITHOUT_LDNS=YES
WITHOUT_LPR=YES
WITHOUT_MAIL=YES
WITHOUT_NAND=YES
WITHOUT_NCP=YES
WITHOUT_NDIS=YES
WITHOUT_NS_CACHING=YES
WITHOUT_PC_SYSINSTALL=YES
WITHOUT_PF=YES
WITHOUT_PMC=YES
WITHOUT_PROFILE=YES
WITHOUT_QUOTAS=YES
WITHOUT_RCMDS=YES
WITHOUT_RCS=YES
WITHOUT_ROUTED=YES
WITHOUT_SHAREDOCS=YES
WITHOUT_SSP=YES
WITHOUT_SYSINSTALL=YES
WITHOUT_TESTS=YES
WITHOUT_UNBOUND=YES
WITHOUT_WIRELESS=YES
WITHOUT_WIRELESS_SUPPORT=YES
WITHOUT_ZFS=YES
But running make buildworld I get this error:

Code:
cc  -fpic -DPIC  -O2 -pipe -mmmx -mtune=pentium2 -march=pentium2 -I/usr/src/lib/libproc -DNDEBUG -std=gnu99  -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -c /usr/src/lib/libproc/proc_regs.c -o proc_regs.So
cc  -fpic -DPIC  -O2 -pipe -mmmx -mtune=pentium2 -march=pentium2 -I/usr/src/lib/libproc -DNDEBUG -std=gnu99  -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -c /usr/src/lib/libproc/proc_sym.c -o proc_sym.So
cc  -fpic -DPIC  -O2 -pipe -mmmx -mtune=pentium2 -march=pentium2 -I/usr/src/lib/libproc -DNDEBUG -std=gnu99  -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -c /usr/src/lib/libproc/proc_rtld.c -o proc_rtld.So
cc  -fpic -DPIC  -O2 -pipe -mmmx -mtune=pentium2 -march=pentium2 -I/usr/src/lib/libproc -DNDEBUG -std=gnu99  -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -c /usr/src/lib/libproc/proc_util.c -o proc_util.So
bmake[4]: /usr/obj/usr/src/lib/libproc/.depend, 377: ignoring stale .depend for /usr/obj/usr/src/tmp/usr/lib/libstdc++.a
building shared library libproc.so.2
/usr/obj/usr/src/tmp/usr/bin/ld: cannot find -lsupc++
*** Error code 1

Stop.
bmake[4]: stopped in /usr/src/lib/libproc
*** Error code 1

Stop.
bmake[3]: stopped in /usr/src/lib
*** Error code 1

Stop.
bmake[2]: stopped in /usr/src
*** Error code 1

Stop.
bmake[1]: stopped in /usr/src
*** Error code 1

Stop.
bmake: stopped in /usr/src
*** [buildworld] Error code 1

Stop in /usr/src.
What am I doing wrong?
 
OP
ORTO-DOX

ORTO-DOX

Member

Reaction score: 1
Messages: 78

Issue solved by applying other note from /usr/src/UPDATING
20130906:
The GNU Compiler Collection and C++ standard library (libstdc++)
are no longer built by default on platforms where clang is the system
compiler. You can enable them with the WITH_GCC and WITH_GNUCXX
options in src.conf.
 
Top