Solved [SOLVED] BTX Halted when compiled with Clang

ShruggingAtlas

Member

Reaction score: 10
Messages: 36

I am running an aging server which has had no problems running FreeBSD since version 7. When I started running FreeBSD 9 things were fine, but I decided to test switching to llvm/clang as the compiler. Building world and kernel with clang works just fine, but after rebooting I get a BTX halted error complete with register dump just after the listing of BIOS drives. I left my experiment alone and ran with GCC, but now I am trying to upgrade to 10.0 and I am seeing exactly the same problem. I can boot from a USB stick or CD without problem, but would rather no have to.

The server hardware:
  • Supermicro Motherboard HD8-something with an AMIBIOS
  • 2 x AMD Opteron 2347HE
  • 32 GB registered Crucial PC5300 RAM
  • 3WARE 9650-4LPML controller with 4 3 TB Toshiba disks attached (disks are a new addition but recognized)

I don't have a lot of experience with programming at the level of boot code, so I would appreciate any suggestions that might help find a solution or prepare a better bug report. I intend to try rebuilding /usr/src/sys/boot2 with GCC to see if that helps.

Thanks for reading.

EDIT: In this case the solution was to disable the motherboard's IDE controller through the BIOS.
 
Top