Slow video playback with mplayer, but mpv works fine

tOsYZYny

Active Member

Reaction score: 15
Messages: 213

I have 3 video players installed:

1. vlc - no sounds for a large # of videos downloaded via youtube-dl
2. mplayer - plays all videos I download via youtube-dl, but I run into a slow or choppy video (I'm using nvidia-driver-440 and an nvidia 1050 ti)
3. mpv - this plays just fine with both software and hardware decoding support. If I don't specify hardware decoding, the CPU usage is 155%, but with it, it is 7%!

Why does mpv seem to work better here? Can I get mplayer running more smoothly? With the audio and vlc, I would think vlc can play it as it has opus support.

I am happy with the performance and ease of use of mpv, so I will likely just use it, but I would think the others should work and work well.

.
 

Zvoni

Active Member

Reaction score: 110
Messages: 185

1. No Idea
2. Something i noticed with mplayer, but on Linux-Machines:
On a Linux-Machine i had vlc and mplayer installed, and had trouble playing 2.7K/60fps-Videos on it.
After a Hardware-Upgrade (i7-processors), i noticed (using conky), that in vlc the videos played with no problems with vlc using all 8 cores, but mplayer still had trouble (slow-motion!) with using only 1 core, so my money would be that mplayer (and in that vein actually it would be ffplay, since mplayer is just a wrapper around ffplay) is not running in multithread-mode
3. No Idea
 
OP
T

tOsYZYny

Active Member

Reaction score: 15
Messages: 213

Thanks, I forgot to mention that I came across a similar post for mplayer and was already trying -vo vdpau, but that didn't work. I need to dig more. In the meantime though, mpv works reliably.
 

olli@

Daemon
Developer

Reaction score: 1,262
Messages: 1,140

Similar setup here (Nvidia GT1030 + nvidia-driver-440), and -vo vdpau works fine.
Among others, I have the following lines in my ~/.mplayer/config:
Code:
af=scaletempo
framedrop=true
vc=ffmpeg1vdpau,ffmpeg2vdpau,ffhevcvdpau,ffh264vdpau,ffodivxvdpau,
vo=vdpau
Note that some features don’t work when hardware acceleration is enabled, e.g. taking screenshots.

If VDPAU doesn’t work for you, install vdpauinfo (multimedia/vdpauinfo) and run it. It should print a screenful of information if VDPAU is supported correctly.

If you have compiled the mplayer port yourself, make sure that you haven’t disabled VDPAU support. It’s enabled by default on i386 and amd64 platforms, but disabled on others.
 
Top