Solved slim xorg fr

CiotBSD

New Member

Reaction score: 3
Messages: 18

As i'm french, i configure my session for the french language.
I use XFCE4, and Slim as session manager.

I configured /etc/profile, as:
Code:
# $FreeBSD: releng/11.0/etc/profile 208116 2010-05-15 17:49:56Z jilles $
#
# System-wide .profile file for sh(1).
#
# Uncomment this to give you the default 4.2 behavior, where disk
# information is shown in K-Blocks
# BLOCKSIZE=K; export BLOCKSIZE
#
# For the setting of languages and character sets please see
# login.conf(5) and in particular the charset and lang options.
# For full locales list check /usr/share/locale/*
# You should also read the setlocale(3) man page for information
# on how to achieve more precise control of locale settings.
#
# Check system messages
# msgs -q
# Allow terminal messages
# mesg y
CHARSET=UTF-8; export LANG
GDM_LANG=fr_FR.UTF-8; export GDM_LANG
LANG=fr_FR.UTF-8; export LANG
LC_ALL=fr_FR.UTF-8; export LC_ALL
LC_COLLATE=fr_FR.UTF-8; export LC_COLLATE
LC_CTYPE=fr_FR.UTF-8; export LC_CTYPE
LC_NUMERIC=fr_FR.UTF-8; export LC_NUMERIC
LC_MESSAGES=fr_FR.UTF-8; export LC_MESSAGES
LC_MONETARY=fr_FR.UTF-8; export LC_MONETARY
LC_TIME=fr_FR.UTF-8; export LC_TIME
SLIM_LANG=fr_FR.UTF-8; export SLIM_LANG

My personal .xinitrc:
Code:
LANG="fr_FR.UTF-8"; export LANG
LC_ALL="fr_FR.UTF-8"; export LC_ALL
MM_CHARSET="fr_FR.UTF-8"; export MM_CHARSET
export HISTTIMEFORMAT="%F %T : "

startxfce4

And active
Code:
slim_enable="YES"
into /etc/rc.conf!

At the first time, i've not configured Xorg.
And when Slim launch, the keyboard is into English Language!
Trouble :(

I disable slim, launch xfce4 in my user session, and XFCE4 is really into French!

How obtain French keyboard for slim manager?!
It's really a problem to tape password with azerty keyboard... for a "FR" password, into "EN" language. :p
(because my pass is an mnemonic password, with maj, min, chiffers, and alfanumerics ...)

I attempt to configure files for Xorg, as:
Code:
# less /usr/local/etc/X11/xorg.conf.d/keyboard.conf
Section "InputClass"
        Identifier "Keyboard0"
        Driver "kbd"

        Option "CoreKeyboard"
        Option "XkbLayout"      "fr"
        Option "XkbModel"       "pc105"
        Option "XkbRules"       "xorg"
        Option "XkbVariant"     "latin9"
EndSection

Ok, Slim recognize French keyboard... but, when i log in my XFCE Session, the mouse is not recognize.

I wrote another file config for X, as:
Code:
# less /usr/local/etc/X11/xorg.conf.d/mouse.conf
Section "InputDevice"
        Identifier "Mouse0"
        Driver "mouse"

        Option "Device"         "/dev/sysmouse"
        Option "Protocol"       "auto"
        Option "ZAxisMapping"   "4 5 6 7"
EndSection
But, not function. Xorg hang!

At this time, to use XFCE Session in French, without any problem, i disable slim, rename files config Xorg into .svg, and launch session by 'starxfce4' after connect-me into my user session!
 

lme@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 303
Messages: 776

Do you have "moused_enable=YES" in /etc/rc.conf
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

Yes, sir :p

Code:
# egrep "mouse" /etc/rc.conf
moused_enable="YES"
moused_type="auto"
 

formateur_fou

Member

Reaction score: 13
Messages: 62

The keyboard configuration is described in the chapter 5.4.7 of the Handbook. In most cases you should not do anything to have your mouse working.
The mouse reference in /etc/rc.conf is only needed if you want mouse support in the console.
Adding locales in ~/.xinitrc should be enough to get all X applications translated in the language of your choice for your specific user.
You can also have a look at the file /var/log/Xorg.0.log to see what is wrong with your configuration.
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

To set files config Xorg, i used the Handbook ;-)

And no, Slim stay in ENglish, even if you refuse to believe me!
(i know another french user than test with same result)!

I'm going to mv files config xorg from .svg to .conf in the /usr/local/etc/X11/xorg.conf.d/, lauching new Xorg server, cp the log (into the pastebin) to publy here ;-)
 

olivierd

Active Member

Reaction score: 80
Messages: 127

Why would you like to have Slim in French, there is no translation files.

Keep in mind if you change files in /etc, it is only for the base system. In Handbook, there is chapter about localization settings, but it is not related to X.org.

If you want to use the French azerty keyboard under your X session, I use this settings (for keyboard) 10-keyboard.conf:

Code:
Section "InputClass"
        Identifier "Keyboard0"
        Driver "kbd"
        MatchIsKeyboard "on"
        Option "XkbModel" "pc105"
        Option "XkbRules" "xorg"
        Option "XkbLayout" "fr"
        Option "XkbVariant" "oss"
EndSection

For mouse (don't add its supports in /etc/rc.conf) (10-mouse.conf):

Code:
Section "InputClass"
        Identifier "Mouse0"
        Driver "mouse"
        MatchIsPointer "on"
EndSection

Place these files into xorg.conf.d/ directory (see man Xorg(1) for commonly used locations).

Now Xorg launches the French keyboard, but your session is not necessarily in French, you must export at least two environment variables (LANG and LC_CTYPE) in .xinitrc.

I see you use Xfce, stop to use your own .xinitrc, use rather /usr/local/etc/xdg/xfce4/xinitrc (it is more complete, better support of DBus, variables environment and so on):

Code:
cp /usr/local/etc/xdg/xfce4/xinitrc ~/.xinitrc
 

kuniyoshi

New Member


Messages: 3

Hello.

I am a French user of FreeBSD 11.0-RELEASE (as CiotPdt). I use the FreeBSD operating system since RELEASE 9 *. I confirm that the following passage of the Handbook

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html

did not allow me to locate my Mate session in French.

To solve my problem, I had to generate xorg.conf, I had to set it up by hand and I wrote

Code:
Option "AutoAddDevices" "false"

that my session is fully localized in French (including Xterm terminal).

URL: https://www.freebsd.org/doc/handbook/x11-understanding.html

NB: Sorry for my English. I do not usually but I decided to make an effort! :)
 

olivierd

Active Member

Reaction score: 80
Messages: 127

Hello.

I am a French user of FreeBSD 11.0-RELEASE (as CiotPdt). I use the FreeBSD operating system since RELEASE 9 *. I confirm that the following passage of the Handbook

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html

did not allow me to locate my Mate session in French.

To solve my problem, I had to generate xorg.conf, I had to set it up by hand and I wrote

Code:
Option "AutoAddDevices" "false"

that my session is fully localized in French (including Xterm terminal).

URL: https://www.freebsd.org/doc/handbook/x11-understanding.html

NB: Sorry for my English. I do not usually but I decided to make an effort! :)

I'm also a French FreeBSD user :) There is no relation between Xorg and your locale.

Xorg interacts with your peripherals (keyboard, mouse, touchpad, and so on). You can have QWERTY keyboard with French locale. I just gave my settings.

If you want to have French session under Mate, I think you need to define LANG and LC_CTYPE in .xinitrc (this file is needed when we use SLim or Xdm as login manager, or without).

I have French session under Xfce, LXQt and Pantheon (desktop from elementary OS).

The option you mentionned, is obsolete (even when xorg-server not used devd backend, I removed this option for long time).
 

kuniyoshi

New Member


Messages: 3

Hello. :)

Yes I wanted to do fast and I expressed myself badly. By configuring the file ~ / .xinitrc :

Code:
export LANG="fr_FR.UTF-8"
export LC_ALL="fr_FR.UTF-8"
setenv LANG fr_FR.UTF-8
exec /usr/local/bin/mate-session

Mate is in French, but Xorg (and slim) is not localized in French. Yet I have

Code:
Section "InputDevice"
       Identifier  "Keyboard0"
        Driver      "kbd"
        Option  "CoreKeyboard"
        Option  "XkbRules"      "xorg"
        Option  "XkbModel"      "pc105"
        Option  "XkbLayout"     "fr"
        Option  "XkbVariant"    "latin9"
EndSection

in the file /usr/local/etc/X11/xorg.conf.

To solve this, I added `Option "AutoAddDevices" "false"` here :

Code:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "AutoAddDevices" "false"
Option "AIGLX" "true"
EndSection

as shown here

https://www.freebsd.org/doc/handbook/x11-understanding.html

and it works well on my system ? (Mate in French and Xorg in French and slim in French.)

But not for CiotPdt. Strange. No ?

URL (in french) : https://cyrille-borne.com/forum/showthread.php?tid=656

The option you mentionned, is obsolete (even when xorg-server not used devd backend, I removed this option for long time).

Ok. I understand but this option appears explicitly in the Handbook so I used.
 

olivierd

Active Member

Reaction score: 80
Messages: 127

I forgot to say, I never touched /etc/profile.

There is section for localization (it's only for base system, changes are not propagated to X.org). I always use login class (French) on my desktop (and server).
 

kuniyoshi

New Member


Messages: 3

Thank you for your answers Olivierd.

Why add Core* option, in Handbook (Input Devices section) example does not mention it. Moreover it gives settings for French users.

Because I use a Xorg configuration I used Gentoo Linux on the same laptop. I used this configuration, adapting it to FreeBSD. Sorry! You are right. ;-)

SLim does not provide translation files (it will be always in English), if you want a login manager more friendly, install x11/gdm or x11/kde4-workspace (for Kdm).

The concern is not with slim that his "presentation" in French (eg : Bienvenue beau gosse) because it is effectively in English and this aspect is not important ! The concern CiotPdt is that the keyboard is QWERTY when used to write their password. Personally, I do not have this problem with my configuration file "xorg.conf" but this is not the case with CiotPdt that creates configuration files in `/usr/local/etc/X11/xorg.conf.d/`.

Difficult to give technical explanations in English. ;-)

Here is a link in French:

http://obsd4a.net/qa/index.php?qa=1108&qa_1=current-cupsd-imprimer

I forgot to say, I never touched /etc/profile.

There is section for localization (it's only for base system, changes are not propagated to X.org). I always use login class (French) on my desktop (and server).


Again thank you Olivier. I take good note. For my part, in light of what you've written, I will try to locate my FreeBSD system without using `xorg.conf` file.
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

My English must be very, really, very badly!
(sorry, for this...)

I do not want Slim into french. Do it really necessary?
I Want use my keyboard into French language when i attempt to login with Slim. But, Slim seems to be, and stays, in English mode.

----

Autrement dit, en bon français ...

Mon clavier est configuré en Français, parce que j'utilise un clavier Azerty, et que je suis francais. De fait, lors de l'installation, j'ai "configuré" un mot-de-passe, en Français, compliqué, de plus de 13 lettres, combinant majuscules, minuscules, chiffres, et caractères alphanumériques (tels que #, /, etc...). Or, au moment de l'écran de session Slim, le clavier est/reste en langue anglaise ... résultat, pour taper le mot-de-passe correspondant, cela devient très difficile.

La seule manière est de configurer X de manière à ce qu'il comprenne le français. Afin, que je puisse taper mon mot-de-passe, en Francais, avec le gestionnaire de session, Slim.
Hors, une fois X configuré pour comprendre le français, Slim fonctionne correctement, mais c'est la session Xfce qui pose problème, à cause d'un problème de reconnaissance matériel, et ce malgré la configuration des fichiers dans /usr/local/etc/X11/xorg.conf.d/, tel qu'écrit plus haut, dans mon premier post.

----

Sorry, english users, to disgress with this French words!

kuniyoshi: Ty! (merci beaucoup)
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

Ok, olivierd: finally, i succeed! :D
But, into your file xorg config about mouse, the option MatchIsPointer "on" hang X server!

Code:
[    22.680]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    22.680] X Protocol Version 11, Revision 0
[    22.680] Build Operating System: FreeBSD 11.0-RELEASE-p1 amd64
[    22.680] Current Operating System: FreeBSD ptb-aw13zou 11.0-RELEASE-p2 FreeBSD 11.0-RELEASE-p2 #0: Mon Oct 24 06:55:27 UTC 2016     root@amd64-builder.daemonology.net:/usr/obj/usr/src/s$
[    22.680] Build Date: 16 October 2016  04:53:46PM
[    22.680]
[    22.680] Current version of pixman: 0.34.0
[    22.680]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    22.680] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.680] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov  8 15:40:30 2016
[    22.771] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[    22.814] Parse error on line 4 of section InputDevice in file /usr/local/etc/X11/xorg.conf.d/mouse.conf
        "MatchIsPointer" is not a valid keyword in this section.
[    22.814] (EE) Problem parsing the config file
[    22.814] (EE) Error parsing the config file
[    22.814] (EE)
Fatal server error:
[    22.814] (EE) no screens found(EE)
[    22.814] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    22.814] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    22.814] (EE)
[    22.814] (EE) Server terminated with error (1). Closing log file.

----

i have a good result by this action:

=> comment all declarations about mouse into /etc/rc.conf! (and re-active slim)
Code:
#moused_enable="YES"
#moused_type="auto"
(...)
slim_enable="YES"

=> change my .xinitrc, by copying /usr/local/etc/xdg/xfce4/xinitrc into my home directory folder, and adding the needed LANG variables.
Code:
#!/bin/sh

LANG="fr_FR.UTF-8"; export LANG
LC_ALL="fr_FR.UTF-8"; export LC_ALL
MM_CHARSET="fr_FR.UTF-8"; export MM_CHARSET

# fix broken $UID on some system...
(...)



=> about my personals files config X are:
Code:
# less /usr/local/etc/X11/xorg.conf.d/keyboard.conf
Section "InputClass"
        Identifier "Keyboard0"
        Driver "kbd"
        MatchIsKeyboard "on"
        Option "CoreKeyboard"
        Option "XkbLayout"      "fr"
        Option "XkbModel"       "pc105"
        Option "XkbRules"       "xorg"
        Option "XkbVariant"     "latin9"
EndSection

And:
Code:
# less /usr/local/etc/X11/xorg.conf.d/mouse.conf
Section "InputDevice"
        Identifier "Mouse0"
        Driver "mouse"
#       MatchIsPointer  "on"
        Option "Device"         "/dev/sysmouse"
        Option "Protocol"       "auto"
        Option "ZAxisMapping"   "4 5 6 7"
EndSection

I rebooted my laptop, and now Slim understand my french config keyboard, and into the session, egual!
(I had to change the keyboard configuration in the system settings: Settings > Keyboard > Layout: Add French layout! run correctlly)
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

olivierd: i'm not agree with you!

The Handbook and the mousedrv manpage inform as i wrote ;)
and the Xorg.conf manpage "says":
The following obsolete section names are still recognised for compatibility purposes. In new config files, the InputDevice section should be used instead.

Keyboard Keyboard configuration
Pointer Pointer/mouse configuration
Thoses options "Match*" run only with oldiers section "InputClass".

And, it's run... correctly.
 
Top