Xfce Slim + XFCE: Slow log-in and grayed-out shutdown/reboot buttons (DBus issue?)

TobiasW

New Member

Reaction score: 2
Messages: 11

Hi,

My Slim + XFCE configuration causes following issue:

First login is fast, everything is fine, shutdown/reboot buttons are available.
On re-log it takes about one minute (timeout?) until the desktop is shown.

/var/log/slim.log says:
Code:
slim: waiting for X server to begin accepting connections.

Furthermore the shutdown/reboot buttons are grayed out (which is not the case on first log-in).

When I change the default content of ~/.xinitrc from
. /usr/local/etc/xdg/xfce4/xinitrc (as recommended in the handbook https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11-wm.html )
to
exec dbus-launch --exit-with-session startxfce4 (as mentioned in https://forums.freebsd.org/threads/xfce-with-slim-produces-dbus-errors.35593/ )
the attached error message is shown and I get redirected to slim (again after one minute or so).

To me this error message (and the greyed-out shutdown/reboot buttons without changes to ~/.xinitrc) indicate some issue regarding DBus.

Unfortunately, there is no such a thing as a DBus log or debugging (as it needs to be compiled into it - if I understand dbus-daemon() correctly).

Did anyone of you experience a similar issue or could give me a hint?

Best,
Tobias
 

Attachments

  • freebsd_xfce_login_error.jpg
    freebsd_xfce_login_error.jpg
    127.4 KB · Views: 66

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,305
Messages: 38,827

Is dbus enabled and running?
 
OP
TobiasW

TobiasW

New Member

Reaction score: 2
Messages: 11

Thanks for the reply. Indeed, dbus is enabled and running.
Without running dbus XFCE would not start at all (which it does after reboot or a few minutes of waiting).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,305
Messages: 38,827

Try without Slim first. Just disable it. Does XFCE start correctly if you run startxfce4?
 
OP
TobiasW

TobiasW

New Member

Reaction score: 2
Messages: 11

Thank you for this advice! It is a good idea to test the involved subsystems seperately...

If I use startxfce4 (or startx) manually the same D-Bus issue occurs (on the second subsequent execution within a short period of time). Therefore, slim does not seem to be the issue.

However, I get additional information as startx gives some feedback. In particular
Code:
(xfce4-session:16859): dbind-WARNING **: 09:30:58.280: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
points towards dbus again.

The complete error log is attached.

I looked up the message and some Linux topics talk about similar messages and suggest installing the library at-spi2-core.
I did not try it, yet. I somehow feel that it won't help...

I noticed that there is no issue if I log in with another user (or wait for about 5 minutes).
Feels like D-Bus needs some time until it can be started again.

I would appreciate further suggestions/ideas :)

Best,
Tobias
 

Attachments

  • startx.txt
    6.9 KB · Views: 41
Last edited:

tedbell

Active Member

Reaction score: 122
Messages: 240

Code:
To be able to shutdown or reboot your system, you'll have to add .rules
files in /usr/local/etc/polkit-1/rules.d directory. Which looks
like this (replace PUTYOURGROUPHERE by your group):

polkit.addRule(function (action, subject) {
  if ((action.id == "org.freedesktop.consolekit.system.restart" ||
      action.id == "org.freedesktop.consolekit.system.stop")
      && subject.isInGroup("PUTYOURGROUPHERE")) {
    return polkit.Result.YES;
  }
});

For those who have working suspend/resume:

polkit.addRule(function (action, subject) {
  if (action.id == "org.freedesktop.consolekit.system.suspend"
      && subject.isInGroup("PUTYOURGROUPHERE")) {
    return polkit.Result.YES;
  }
});
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,305
Messages: 38,827

In particular
Code:
(xfce4-session:16859): dbind-WARNING **: 09:30:58.280: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
points towards dbus again.
Yeah, that error doesn't look good. Maybe your running dbus is just hung up, or has had some other failure. Try stopping it with a regular service dbus stop. Then check if there are no dbus processes running any more. Kill them if necessary. Start dbus; service dbus start. Check if there's a dbus process running. At the very least you should have one process running as /usr/local/bin/dbus-daemon --system. That's the "master", it is the one everything else connects to.

Looking a bit further it seems to specifically mention "accessibility". That's for things like magnifying glass and various improvements/addons to help disabled people.
 

Columbo0815

New Member

Reaction score: 2
Messages: 13

It seems to be a new and general problem. I have installed xfce (... and gdm/sddm) for several years. Since a few days (?) the login is slow. Sometimes the shutdown/reboot-buttons aren't available.
 
Top