[SLIM + MATE with UEFI] SLIM starts but nothing on screen ?

valenciano8

New Member

Reaction score: 1
Messages: 6

Greetings everyone,

I'm a GNU/Linux user (Fedora), and I just wanted to give FreeBSD a try with a Virtual MAchine (VBox).

First I tried to install FreeBSD with BIOS mode and slim and MATE desktop according to this guide :


Result : Works great

But, when I tried to create a brand new Virtual Machine with UEFI mode, everything worked except that I have no GUI, I stay with tty :

6452


Do you have any idea why the same operations wouldn't work with UEFI mode ? Because according to the prompt, everything works but as you can see it stays with the Console...

Kind Regards
 
OP
V

valenciano8

New Member

Reaction score: 1
Messages: 6

Hi SirDice !

Thank you for your answer.

Well, I did isntall the vbox guest additions afterall but nothing...

Here is the output after typing "startx" :

6453
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

You'll need to configure Xorg and tell it to use the Virtualbox driver. For some reason it never auto-detected it for me.

This should help: 21.5. FreeBSD as a Guest on VirtualBox™

But I see it's a little old. Do ,make sure you enabled the services that are mentioned.

Create /usr/local/etc/X11/xorg.conf.d/driver-vbox.conf:
Code:
Section "Device"
	Identifier "Card0"
	Driver "vboxvideo"
	VendorName "InnoTek Systemberatung GmbH"
	BoardName "VirtualBox Graphics Adapter"
EndSection

That should be more than enough. Remove any /etc/X11/xorg.conf or /usr/local/etc/X11/xorg.conf if you have them.
 
OP
V

valenciano8

New Member

Reaction score: 1
Messages: 6

Well, I did exactly what you told me to do but here is the result :

6454
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

No, you didn't do exactly what I told you, you still have a /etc/X11/xorg.conf, which should be removed. Perhaps this wasn't clear, just remove all xorg.conf files. And only create the /usr/local/etc/X11/xorg.conf.d/driver-vbox.conf as shown above.

If you still have problems, please provide the /var/log/Xorg.0.log, we need to see what's being detected (or not being detected).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

I swear 🙌 :
Look closely at the picture you posted in post #5.
Code:
(==) Using config file: /etc/X11/xorg.conf

But lets move on. If you look at the last picture you posted you can see it's unable to find the vboxvideo driver. Double check if emulators/virtualbox-ose-additions is actually installed succesfully, the vboxvideo driver is included with that.

And I assume you have network access in the VM? Then install misc/pastebinit. That will make it easier to post logs: cat /var/log/Xorg.0.log | pastebinit.
 
OP
V

valenciano8

New Member

Reaction score: 1
Messages: 6

Great that works now thanks ! You were right, I thought I already installed the vbox guest additions but nope, thank you again !
 
Top