Slim log error

philo_neo

Well-Known Member

Reaction score: 6
Messages: 260

I use FreeBSD 13, I installed the X server, to start I tested xfce4 as a window manager, it works very well, I did not activate the loading of the desktop automatically but manually I did a startxfce4. Curiosity pushes me to install Kde5, that's what I did. I chose Slim and not Sddm as the login loader when connecting my KDE desktop. Slim does not log in, the screen stays on Slim's crosshairs without loading the desktop. As I am afraid of making errors in the settings of Slim, I have written to you to solve my problem.
this the sample of /etc/rc.conf:

Code:
dbus_enable="YES"
hald_enable="YES"
# sddm_enable="YES"
kdm4_enable=”YES”
slim_enable="yes"
gdm_enable="YES"

run command with powerless user :

Code:
% echo "exec /usr/local/bin/startkde5 --with-ck-launch" > ~/.xinitrc
% echo "#!/bin/sh" > ~/.xsession
% echo "exec /usr/local/bin/startkde5 --with-ck-launch" >> ~/.xsession
% chmod +x ~/.xsession

it seems that Slim is not synchronous with the users of my station.
what do you need to configure?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,976
Messages: 40,708

Remove hald_enable (HAL is not installed anymore), kdm4_enable (KDE4 is long gone) and gdm_enable (is also a display manager, you can run only one).

For SLiM to work correctly (including the WM/DE selection) use this in your ~/.xinitrc (SLiM passes the selected WM/DE via an argument):
Code:
[ -n "$1" ] && [ -x "$1" ] && exec "$1"
There's no need for the shebang line (although it doesn't hurt to add it), and no need to set the file executable (file is sourced, not executed).

As I am afraid of making errors in the settings of Slim,
You don't need to make changes to slim.conf, the default configuration works just fine.

When logging in on SLiM, press F1 to select the WM/DE you want to have for that session. Make sure you're not selecting "KDE (Wayland)" as that uses Wayland and requires a lot more to set up correctly.
 
OP
philo_neo

philo_neo

Well-Known Member

Reaction score: 6
Messages: 260

SirDice,
I applied the parameters you told me, I modified the rc.conf so that it loads a single graphic daemon. Then modified ~/.xinitrc:. When Slim is loaded, pressing F1 gives me a choice of three states: plasma session (X11), Xfce session and user session. Alas Slim remains static, it does not interact with the different registered users. The Kde or Xfce desktop does not launch! I know something is missing because a few years ago I had Slim setting on Sparc64 hardware, all worked fine.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,976
Messages: 40,708

Then modified ~/.xinitrc
You do realize this has to be done for each individual user? Every user has its own ~/.xinitrc.

The Kde or Xfce desktop does not launch!
Don't use KDE or XFCE but I do have a couple of other WMs, those work just fine. I see no reason why this shouldn't work for KDE or XFCE (I have used those in the past).
 
OP
philo_neo

philo_neo

Well-Known Member

Reaction score: 6
Messages: 260

Each individual user has their own ~/.xinitrc. The station is still on Slim's radar. I've searched the internet but it's still confusing! do you have a preferred WM to install? I think after bypassing Slim's crosshairs I'm doing well. what should be done?
 
OP
philo_neo

philo_neo

Well-Known Member

Reaction score: 6
Messages: 260

I think to abandon Slim as start session of VM, keep KD5 but choose sddm as login. I would like to remove Slim from my system! Install sddm, I would like to know if this is possible?
 
Top